summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/calf/files/calf-9999-fix-build-with-lld.patch')
-rw-r--r--media-plugins/calf/files/calf-9999-fix-build-with-lld.patch27
1 files changed, 7 insertions, 20 deletions
diff --git a/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
index 816da77f7d0d..acd196f6edd2 100644
--- a/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
+++ b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
@@ -1,26 +1,13 @@
-From https://github.com/calf-studio-gear/calf/pull/332/commits/bdaaa92dd82e2425e4683b9d496370c5880e3b3e Mon Sep 17 00:00:00 2001
-From: Violet Purcell <vimproved@inventati.org>
-Date: Thu, 21 Sep 2023 19:08:39 -0400
-Subject: [PATCH] Fix build with LLD
-
-LLVM's LLD handles the -retain-symbols-file option (used by
--export-symbols-regex in libtool) differently from GNU ld, causing
-undefined references during link. This commit removes the
--export-symbols-regex option from libcalf_la_LDFLAGS since by default
-libtool exports all symbols anyway, so it should not be necessary.
-
-Signed-off-by: Violet Purcell <vimproved@inventati.org>
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 6f11628b..0e775bef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -42,7 +42,7 @@ libcalf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS)
+@@ -53,7 +53,7 @@ libcalflv2gui_la_SOURCES = gui.cpp gui_config.cpp gui_controls.cpp ctl_curve.cpp
if USE_DEBUG
- libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ libcalflv2gui_la_LDFLAGS = -rpath $(lv2dir) -avoid-version -module -lexpat $(GUI_DEPS_LIBS) -disable-static -Wl,-z,nodelete
else
--libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static -export-symbols-regex "lv2_descriptor"
-+libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+-libcalflv2gui_la_LDFLAGS = -rpath $(lv2dir) -avoid-version -module -lexpat -export-symbols-regex "lv2ui_descriptor" $(GUI_DEPS_LIBS) -disable-static -Wl,-z,nodelete
++libcalflv2gui_la_LDFLAGS = -rpath $(lv2dir) -avoid-version -module -lexpat $(GUI_DEPS_LIBS) -disable-static -Wl,-z,nodelete
+ endif
endif
- if USE_LV2_GUI
---
-2.42.0
-