summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/ax25-apps')
-rw-r--r--media-radio/ax25-apps/Manifest1
-rw-r--r--media-radio/ax25-apps/ax25-apps-0.0.8_rc4.ebuild48
-rw-r--r--media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch12
-rw-r--r--media-radio/ax25-apps/files/ax25ipd.rc20
-rw-r--r--media-radio/ax25-apps/files/ax25mond.rc20
-rw-r--r--media-radio/ax25-apps/files/ax25rtd.rc20
-rw-r--r--media-radio/ax25-apps/metadata.xml8
7 files changed, 129 insertions, 0 deletions
diff --git a/media-radio/ax25-apps/Manifest b/media-radio/ax25-apps/Manifest
new file mode 100644
index 000000000000..27d4d8376360
--- /dev/null
+++ b/media-radio/ax25-apps/Manifest
@@ -0,0 +1 @@
+DIST ax25-apps-0.0.8-rc4.tar.gz 442172 SHA256 0e031721a440cc169768080f1d6bea32ef1d2a9c80a754ae5239738f9ab8fe0a SHA512 c99b553c5cadb0e389c1cb35e79fea61b628c76f5ef35c35876e492afc7ab796f8781c3ab5987a096f0816389e9772274fe54e88c16fca0fd30013da3d74d38b WHIRLPOOL 0402f5d149642ed479a260a64c091bcd4a797a53e5ac2df239fd3e5d38821c5fe0cbacffe7c2d7ebeb614bc455805269eb415fb73315fd830da9c05310152d8f
diff --git a/media-radio/ax25-apps/ax25-apps-0.0.8_rc4.ebuild b/media-radio/ax25-apps/ax25-apps-0.0.8_rc4.ebuild
new file mode 100644
index 000000000000..62f4777fa5dc
--- /dev/null
+++ b/media-radio/ax25-apps/ax25-apps-0.0.8_rc4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Basic AX.25 (Amateur Radio) user tools, additional daemons"
+HOMEPAGE="http://www.linux-ax25.org"
+SRC_URI="http://www.linux-ax25.org/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libax25-0.0.12_rc2
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ !media-sound/listen
+ !dev-ruby/listen"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "$FILESDIR"/$PN-0.8.4-tinfo.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/ax25ipd.rc ax25ipd
+ newinitd "${FILESDIR}"/ax25mond.rc ax25mond
+ newinitd "${FILESDIR}"/ax25rtd.rc ax25rtd
+
+ rm -rf "${ED}"/usr/share/doc/ax25-apps
+
+ dodoc AUTHORS ChangeLog NEWS README ax25ipd/README.ax25ipd \
+ ax25rtd/README.ax25rtd ax25ipd/HISTORY.ax25ipd ax25rtd/TODO.ax25rtd
+
+ dodir /var/lib/ax25/ax25rtd
+ touch "${ED}"/var/lib/ax25/ax25rtd/ax25_route
+ touch "${ED}"/var/lib/ax25/ax25rtd/ip_route
+}
diff --git a/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch b/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch
new file mode 100644
index 000000000000..ee1c2ffd92b6
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch
@@ -0,0 +1,12 @@
+# fix tinof handling (bug 529776)
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,7 +17,7 @@
+ AC_SUBST(AX25_LIB)
+ AC_SUBST(NCURSES_LIB)
+ AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AC_MSG_ERROR(Could not find the libax25 libraries; aborting))
+-AC_CHECK_LIB(ncurses, initscr,NCURSES_LIB="-lncurses", AC_MSG_ERROR(Could not find the ncurses library; aborting))
++PKG_CHECK_MODULES(ncurses, ncurses, [NCURSES_LIB="$ncurses_LIBS"], AC_MSG_ERROR(Could not find the ncurses library))
+
+ dnl Checks for working glibc 2.1 headers
+ AC_CHECK_TYPES([struct ax25_fwd_struct], [],
diff --git a/media-radio/ax25-apps/files/ax25ipd.rc b/media-radio/ax25-apps/files/ax25ipd.rc
new file mode 100644
index 000000000000..22543fad15ba
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25ipd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25ipd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25ipd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25ipd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25ipd
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25mond.rc b/media-radio/ax25-apps/files/ax25mond.rc
new file mode 100644
index 000000000000..9ce640f758df
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25mond.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25mond"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25mond
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25mond"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25mond
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25rtd.rc b/media-radio/ax25-apps/files/ax25rtd.rc
new file mode 100644
index 000000000000..e051d893e08d
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25rtd.rc
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25rtd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25rtd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25rtd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25rtd
+ eend $?
+}
diff --git a/media-radio/ax25-apps/metadata.xml b/media-radio/ax25-apps/metadata.xml
new file mode 100644
index 000000000000..723553c89120
--- /dev/null
+++ b/media-radio/ax25-apps/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>