summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
index 5cd29c52ea67..f5587f996c28 100644
--- a/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
@@ -54,8 +54,14 @@ src_configure() {
$(meson_feature introspection)
$(meson_feature pulseaudio)
$(meson_feature sasl)
- -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
$(meson_feature vala with-vala)
)
+
+ if use elibc_musl; then
+ emesonargs+=( -Dwith-coroutine=gthread )
+ else
+ emesonargs+=( -Dwith-coroutine=auto )
+ fi
+
meson_src_configure
}