summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3/nghttp3-1.4.0.ebuild')
-rw-r--r--net-libs/nghttp3/nghttp3-1.4.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-libs/nghttp3/nghttp3-1.4.0.ebuild b/net-libs/nghttp3/nghttp3-1.4.0.ebuild
index 0d2dcc6e27ff..b342674b4fa5 100644
--- a/net-libs/nghttp3/nghttp3-1.4.0.ebuild
+++ b/net-libs/nghttp3/nghttp3-1.4.0.ebuild
@@ -18,10 +18,14 @@ HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
LICENSE="MIT"
SLOT="0/0"
-IUSE="static-libs"
+
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ test? ( static-libs )
+"
BDEPEND="virtual/pkgconfig"
-RDEPEND=""
multilib_src_configure() {
local mycmakeargs=(
@@ -29,9 +33,10 @@ multilib_src_configure() {
-DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_EXAMPLES=OFF
)
+ use test && mycmakeargs+=( -DBUILD_TESTING=ON )
cmake_src_configure
}
multilib_src_test() {
- cmake_build check
+ multilib_is_native_abi && cmake_build check
}