summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnsl/libnsl-2.0.0-r1.ebuild (renamed from net-libs/libnsl/libnsl-2.0.0.ebuild)21
1 files changed, 15 insertions, 6 deletions
diff --git a/net-libs/libnsl/libnsl-2.0.0.ebuild b/net-libs/libnsl/libnsl-2.0.0-r1.ebuild
index eb30d9918952..99b3fb7a8a12 100644
--- a/net-libs/libnsl/libnsl-2.0.0.ebuild
+++ b/net-libs/libnsl/libnsl-2.0.0-r1.ebuild
@@ -3,22 +3,22 @@
EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal preserve-libs
DESCRIPTION="Public client interface for NIS(YP) in a IPv6 ready version"
HOMEPAGE="https://github.com/thkukuk/libnsl"
SRC_URI="https://github.com/thkukuk/${PN}/releases/download/v${PV}/${P}.tar.xz"
+# This is a core package which is depended on by e.g. PAM in some cases.
+# Please use preserve-libs.eclass in pkg_{pre,post}inst to cover users
+# with FEATURES="-preserved-libs" or another package manager if SONAME
+# changes.
SLOT="0/3"
LICENSE="LGPL-2.1+"
-
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
IUSE="static-libs"
-DEPEND="
- >=net-libs/libtirpc-1.2.0:=[${MULTILIB_USEDEP}]
-"
+DEPEND=">=net-libs/libtirpc-1.2.0:=[${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}
!<sys-libs/glibc-2.26
"
@@ -28,6 +28,7 @@ multilib_src_configure() {
--enable-shared
$(use_enable static-libs static)
)
+
ECONF_SOURCE=${S} econf "${myconf[@]}"
}
@@ -35,3 +36,11 @@ multilib_src_install_all() {
einstalldocs
find "${ED}" -type f -name '*.la' -delete || die
}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libnsl.so.2
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libnsl.so.2
+}