summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cmst')
-rw-r--r--net-misc/cmst/cmst-2017.03.18.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-misc/cmst/cmst-2017.03.18.ebuild b/net-misc/cmst/cmst-2017.03.18.ebuild
index 36d6de0f600e..9eea2f71f8f3 100644
--- a/net-misc/cmst/cmst-2017.03.18.ebuild
+++ b/net-misc/cmst/cmst-2017.03.18.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit qmake-utils
+inherit gnome2-utils qmake-utils
DESCRIPTION="Qt GUI for Connman with system tray icon"
HOMEPAGE="https://github.com/andrew-bibb/cmst"
@@ -34,3 +34,15 @@ src_install() {
emake INSTALL_ROOT="${D}" install
rm -r "${D}"/usr/share/licenses || die
}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}