summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/livestreamer')
-rw-r--r--net-misc/livestreamer/Manifest4
-rw-r--r--net-misc/livestreamer/livestreamer-1.11.1.ebuild24
-rw-r--r--net-misc/livestreamer/livestreamer-1.12.1.ebuild39
-rw-r--r--net-misc/livestreamer/livestreamer-1.12.2.ebuild39
-rw-r--r--net-misc/livestreamer/livestreamer-1.7.2.ebuild22
-rw-r--r--net-misc/livestreamer/metadata.xml12
6 files changed, 140 insertions, 0 deletions
diff --git a/net-misc/livestreamer/Manifest b/net-misc/livestreamer/Manifest
new file mode 100644
index 000000000000..5fbc60765422
--- /dev/null
+++ b/net-misc/livestreamer/Manifest
@@ -0,0 +1,4 @@
+DIST livestreamer-1.11.1.tar.gz 864035 SHA256 69e2bc2a72fca682e5e328db18cefeef2f32ea59413fb0847dc478abca1f2cc2 SHA512 1edac388ee91540309c396bbc6a426b2008bbc0066fea7a5861517c9f0da49edc1a398e2bf3e8c9a3ab58bfaec9c15d57fff6d72dd8f9b8c8de9c4537f443429 WHIRLPOOL 393e20cb64873e84daf31ff543db7002306e7e37b68710729c024e78f9b566a75bae57220175fd3fae7331cb8c228d72698574c417ab0f93ea901601458e8f8b
+DIST livestreamer-1.12.1.tar.gz 873050 SHA256 3255bc78adbdc233b9586d3b5348134ab5ae656580c9f2489d03068c369a0fb6 SHA512 40d959c0b0884519e6a2a45e28865e76def1ce15d5afaa79e506e552e189e3187e98d26c8dabde5734c2dce7fe2ec8215782e3b4bdd63132b02bc37ff42a4373 WHIRLPOOL a6b6d1e9e3cef7e14f3f50dfbc87653df1dfb155cf524ef936a05a86805ca339035ed13432e1da7f75a1aaf2d15ca52ee9b52fe030f8df6f8fb28b19a5684033
+DIST livestreamer-1.12.2.tar.gz 877052 SHA256 4d6e2954abff198dce082f34a19a54dbf6fb95ca53567d92a661e527fe68e3ba SHA512 547886b494a7562e479cf31db15b5b02545f2ebc5f8b70d0fe0006d3748c5c9f20517638c7642377e2bdc4083738829eacf272e8d68f332da212bf65300f5d12 WHIRLPOOL f898483137a2c3de15512938052cda516a531c1d02990811f8a65ac9c2c0c7f1a55608e659cdadce0dc939b0cf4f294a9133a7af814599787858d1a3435c2e3c
+DIST livestreamer-1.7.2.tar.gz 557683 SHA256 0fba4fe00736992ac31dc3a7edc3850b6d2ff8c4d67ca518db699010f1f12ece SHA512 79db7a020828790372206bf2e145b2fe99e5b94965206f44dbcf553653f88aa4163cc866631202371290eec67bf915de05a5ab348fcb6752c2362f46fc1af15e WHIRLPOOL 782abfe62062ff33a785585364b6506a9c76246d0a7551509a91f90e5bf69052b329aad7bacd4676c2adae4782b966db0481565f20668dd3c75251682621b172
diff --git a/net-misc/livestreamer/livestreamer-1.11.1.ebuild b/net-misc/livestreamer/livestreamer-1.11.1.ebuild
new file mode 100644
index 000000000000..1c0b530b2e22
--- /dev/null
+++ b/net-misc/livestreamer/livestreamer-1.11.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
+HOMEPAGE="https://github.com/chrippa/livestreamer"
+SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+KEYWORDS="amd64 ~mips x86"
+LICENSE="Apache-2.0 BSD-2 MIT-with-advertising"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >media-video/rtmpdump-2.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/net-misc/livestreamer/livestreamer-1.12.1.ebuild b/net-misc/livestreamer/livestreamer-1.12.1.ebuild
new file mode 100644
index 000000000000..805684937b47
--- /dev/null
+++ b/net-misc/livestreamer/livestreamer-1.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
+HOMEPAGE="https://github.com/chrippa/livestreamer"
+SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+KEYWORDS="~amd64 ~mips ~x86"
+LICENSE="Apache-2.0 BSD-2 MIT-with-advertising"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >media-video/rtmpdump-2.4"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/net-misc/livestreamer/livestreamer-1.12.2.ebuild b/net-misc/livestreamer/livestreamer-1.12.2.ebuild
new file mode 100644
index 000000000000..805684937b47
--- /dev/null
+++ b/net-misc/livestreamer/livestreamer-1.12.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
+HOMEPAGE="https://github.com/chrippa/livestreamer"
+SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+KEYWORDS="~amd64 ~mips ~x86"
+LICENSE="Apache-2.0 BSD-2 MIT-with-advertising"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >media-video/rtmpdump-2.4"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/net-misc/livestreamer/livestreamer-1.7.2.ebuild b/net-misc/livestreamer/livestreamer-1.7.2.ebuild
new file mode 100644
index 000000000000..e163f85aabb6
--- /dev/null
+++ b/net-misc/livestreamer/livestreamer-1.7.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
+HOMEPAGE="https://github.com/chrippa/livestreamer"
+SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+KEYWORDS="amd64 ~mips x86"
+LICENSE="Apache-2.0 BSD-2 MIT-with-advertising"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto
+ >=dev-python/requests-1.0
+ >media-video/rtmpdump-2.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
diff --git a/net-misc/livestreamer/metadata.xml b/net-misc/livestreamer/metadata.xml
new file mode 100644
index 000000000000..0cfaa62977f9
--- /dev/null
+++ b/net-misc/livestreamer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>the.telvanni@gmail.com</email>
+ <name>Guillaume Lespinasse</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chrippa/livestreamer</remote-id>
+ </upstream>
+</pkgmetadata>