summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/suite3270/files/Makefile.in')
-rw-r--r--net-misc/suite3270/files/Makefile.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/net-misc/suite3270/files/Makefile.in b/net-misc/suite3270/files/Makefile.in
new file mode 100644
index 000000000000..154b470de801
--- /dev/null
+++ b/net-misc/suite3270/files/Makefile.in
@@ -0,0 +1,10 @@
+# DO NOT STARE AT THE SUN
+VER = @VER@
+_SUBDIRS = @SUBDIRS@
+SUBDIRS = $(_SUBDIRS:=-$(VER))
+all:
+%:; $(MAKE) `printf '%s_$@_ ' $(SUBDIRS)`
+_words = $(subst _, ,$1)
+_dir = $(firstword $(call _words,$@))
+_targ = $(lastword $(call _words,$@))
+%_:; $(MAKE) -C $(_dir) $(_targ) $(EXTRA_TARGETS)