summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild')
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild b/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
deleted file mode 100644
index 2310def0f5ef..000000000000
--- a/net-p2p/go-ethereum/go-ethereum-1.5.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Official golang implementation of the Ethereum protocol"
-HOMEPAGE="https://github.com/ethereum/go-ethereum"
-SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+ LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="evm opencl"
-
-DEPEND="dev-lang/go:=
- opencl? ( virtual/opencl )
-"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- use opencl && export GO_OPENCL=true
-
- emake geth
- use evm && emake evm
-}
-
-src_install() {
- einstalldocs
-
- dobin build/bin/geth
- use evm && dobin build/bin/evm
-}