summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/candy/candy-5.10.3-r1.ebuild')
-rw-r--r--net-vpn/candy/candy-5.10.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/candy/candy-5.10.3-r1.ebuild b/net-vpn/candy/candy-5.10.3-r1.ebuild
new file mode 100644
index 000000000000..b2396261c0bd
--- /dev/null
+++ b/net-vpn/candy/candy-5.10.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd readme.gentoo-r1
+
+DESCRIPTION="A reliable, low-latency, and anti-censorship virtual private network"
+HOMEPAGE="https://github.com/lanthora/candy"
+SRC_URI="https://github.com/lanthora/candy/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ dev-libs/poco:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ dev-libs/libfmt:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_install(){
+ cmake_src_install
+ default
+
+ insinto /etc
+ doins candy.cfg
+
+ systemd_dounit candy.service
+ systemd_dounit candy@.service
+ newinitd candy.initd candy
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}