summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/last/last-299-r1.ebuild')
-rw-r--r--sci-biology/last/last-299-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/last/last-299-r1.ebuild b/sci-biology/last/last-299-r1.ebuild
new file mode 100644
index 000000000000..b6adee215970
--- /dev/null
+++ b/sci-biology/last/last-299-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-single-r1
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-299-fix-build-system.patch
+ "${FILESDIR}"/${PN}-299-portable-shebangs.patch
+)
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ local DOCS=( doc/*.txt ChangeLog.txt README.txt )
+ local HTML_DOCS=( doc/*html )
+ einstalldocs
+
+ dobin src/last{al,db,ex}
+
+ cd scripts || die
+ local i
+ for i in *py; do
+ newbin ${i} ${i%.py}
+ done
+ dobin *sh
+}