summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild')
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild b/sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild
index d0d519b18ce6..3a05960c2cc7 100644
--- a/sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild
+++ b/sci-libs/hipSPARSE/hipSPARSE-5.1.3-r1.ebuild
@@ -71,7 +71,7 @@ src_prepare() {
mkdir -p "${BUILD_DIR}"/clients/matrices
# compile and use the mtx2bin converter. Do not use any optimization flags!
edo $(tc-getCXX) deps/convert.cpp -o deps/convert
- find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).bin
ebegin "Converting ${mtxfile} to ${destination}"