summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocRAND/rocRAND-6.1.1.ebuild')
-rw-r--r--sci-libs/rocRAND/rocRAND-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/rocRAND/rocRAND-6.1.1.ebuild b/sci-libs/rocRAND/rocRAND-6.1.1.ebuild
index 1cfbcdbd04f3..e3b1aa20b634 100644
--- a/sci-libs/rocRAND/rocRAND-6.1.1.ebuild
+++ b/sci-libs/rocRAND/rocRAND-6.1.1.ebuild
@@ -33,6 +33,8 @@ BDEPEND="dev-build/rocm-cmake
>=dev-build/cmake-3.22"
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
@@ -42,7 +44,7 @@ src_configure() {
-DBUILD_BENCHMARK=$(usex benchmark ON OFF)
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {