summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/eclib/eclib-20241112.ebuild')
-rw-r--r--sci-mathematics/eclib/eclib-20241112.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/eclib-20241112.ebuild b/sci-mathematics/eclib/eclib-20241112.ebuild
new file mode 100644
index 000000000000..a1eb3c2a4de6
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20241112.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/14"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}