summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild')
-rw-r--r--sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
index 6575b4594b59..bca99c3cffd5 100644
--- a/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
+++ b/sys-apps/ifd-gempc/ifd-gempc-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit toolchain-funcs
@@ -14,19 +14,24 @@ SLOT="0"
SRC_URI="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/${P}.tar.gz"
IUSE=""
RDEPEND=">=sys-apps/pcsc-lite-1.2.9_beta7
- =virtual/libusb-0*"
+ virtual/libusb:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+DOCS=(
+ README README.410 README.430
+)
+
src_compile() {
emake CC="$(tc-getCC)"
}
src_install () {
+ emake CC="$(tc-getCC)" DESTDIR="${D}" install
+ einstalldocs
+
local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
local conf="/etc/reader.conf.d/${PN}.conf"
- emake CC="$(tc-getCC)" DESTDIR="${D}" install
- dodoc README*
dodir "$(dirname "${conf}")"
insinto "$(dirname "${conf}")"
newins "${FILESDIR}/reader.conf" "$(basename "${conf}")"