summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/qla-fc-firmware')
-rw-r--r--sys-block/qla-fc-firmware/Manifest3
-rw-r--r--sys-block/qla-fc-firmware/metadata.xml12
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild40
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild40
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild40
5 files changed, 135 insertions, 0 deletions
diff --git a/sys-block/qla-fc-firmware/Manifest b/sys-block/qla-fc-firmware/Manifest
new file mode 100644
index 000000000000..67945123d6ec
--- /dev/null
+++ b/sys-block/qla-fc-firmware/Manifest
@@ -0,0 +1,3 @@
+DIST qla-fc-firmware-20071207.tar.bz2 910151 RMD160 17d68a99aabf26553cbeef51f8a12eb28ba8029e SHA1 57fe4e0add291b9a7eef8b6ed1e35ac8bc803bc7 SHA256 fc062041b8f82a72a8229075284280bbafd3d297d4b71dd05f787bcaeb8de58b
+DIST qla-fc-firmware-20080423.tar.bz2 1010881 RMD160 73e23391245e5d0268a5739bc246ceb24ab30a8f SHA1 1e9254426fbed1b06eeccc3c2f504b5cb9fc11f1 SHA256 6ecc88f97860717d42793e5ba7f672aa547b83151f176aefce9bbc8decee5497
+DIST qla-fc-firmware-20101015.tar.bz2 3237889 RMD160 dc7baf8c6733284fe0b38c499fb4c2a41c0af2b3 SHA1 afd6d4b413241d83ec2a1e8a38f0512a03421693 SHA256 e2951f8a130350ca38990afb60d16c4ea3262de5f9a7d9a75c88db04095bb6cb
diff --git a/sys-block/qla-fc-firmware/metadata.xml b/sys-block/qla-fc-firmware/metadata.xml
new file mode 100644
index 000000000000..de72ca25f268
--- /dev/null
+++ b/sys-block/qla-fc-firmware/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription>
+ QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards.
+ This package contains snapshots of firmware releases from the QLogic FTP server.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild
new file mode 100644
index 000000000000..cb62d6c97d6c
--- /dev/null
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20071207-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
+HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="qlogic-fibre-channel-firmware"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+# really depends on absolutely nothing
+DEPEND=""
+RDEPEND="!sys-kernel/linux-firmware"
+
+FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
+
+src_install() {
+ # We must install this, say QLogic's people.
+ # They have claimed to me that the /license/ directory isn't sufficient, as
+ # there is no guarantee it will be on a system - and it would not be in any
+ # binpkg either. If you do something else with the firmware blobs, you are
+ # thus strongly encouraged to keep a copy of the LICENSE file with them on
+ # the system.
+ dodoc LICENSE
+ dodoc README.* CURRENT_VERSIONS
+ insinto /lib/firmware
+ # some older firmware are always provided by upstream
+ # for reasons documented in CURRENT_VERSIONS.
+
+ # Please see README.* as to why we do not use the MID/MIDX versions by
+ # default if they are newer.
+ # TODO: Provide a means to get them for people that really want them.
+ for f in ${FW_BASENAME} ; do
+ doins ${f}.*
+ latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
+ dosym ${latest_f} /lib/firmware/${f}
+ done
+}
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild
new file mode 100644
index 000000000000..ddcac4651f67
--- /dev/null
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20080423.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
+HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="qlogic-fibre-channel-firmware"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# really depends on absolutely nothing
+DEPEND=""
+RDEPEND="!sys-kernel/linux-firmware"
+
+FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
+
+src_install() {
+ # We must install this, say QLogic's people.
+ # They have claimed to me that the /license/ directory isn't sufficient, as
+ # there is no guarantee it will be on a system - and it would not be in any
+ # binpkg either. If you do something else with the firmware blobs, you are
+ # thus strongly encouraged to keep a copy of the LICENSE file with them on
+ # the system.
+ dodoc LICENSE
+ dodoc README.* CURRENT_VERSIONS
+ insinto /lib/firmware
+ # some older firmware are always provided by upstream
+ # for reasons documented in CURRENT_VERSIONS.
+
+ # Please see README.* as to why we do not use the MID/MIDX versions by
+ # default if they are newer.
+ # TODO: Provide a means to get them for people that really want them.
+ for f in ${FW_BASENAME} ; do
+ doins ${f}.*
+ latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
+ dosym ${latest_f} /lib/firmware/${f}
+ done
+}
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild
new file mode 100644
index 000000000000..e21cf1070a68
--- /dev/null
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
+HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="qlogic-fibre-channel-firmware"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+# really depends on absolutely nothing
+DEPEND=""
+RDEPEND="!sys-kernel/linux-firmware"
+
+FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
+
+src_install() {
+ # We must install this, say QLogic's people.
+ # They have claimed to me that the /license/ directory isn't sufficient, as
+ # there is no guarantee it will be on a system - and it would not be in any
+ # binpkg either. If you do something else with the firmware blobs, you are
+ # thus strongly encouraged to keep a copy of the LICENSE file with them on
+ # the system.
+ dodoc LICENSE
+ dodoc README.* CURRENT_VERSIONS
+ insinto /lib/firmware
+ # some older firmware are always provided by upstream
+ # for reasons documented in CURRENT_VERSIONS.
+
+ # Please see README.* as to why we do not use the MID/MIDX versions by
+ # default if they are newer.
+ # TODO: Provide a means to get them for people that really want them.
+ for f in ${FW_BASENAME} ; do
+ doins ${f}.*
+ latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
+ dosym ${latest_f} /lib/firmware/${f}
+ done
+}