summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/Manifest2
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch56
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild75
-rw-r--r--sys-power/hibernate-script/metadata.xml7
4 files changed, 140 insertions, 0 deletions
diff --git a/sys-power/hibernate-script/Manifest b/sys-power/hibernate-script/Manifest
new file mode 100644
index 000000000000..02d806959c94
--- /dev/null
+++ b/sys-power/hibernate-script/Manifest
@@ -0,0 +1,2 @@
+DIST hibernate-script-2.0-patches-4.tar.bz2 4209 SHA256 525260253be33ee6115d733ceef84de86a9161219c8503c106fa75d62e0ff2c3 SHA512 7fadffe0b749b202c3e26795a8fdbf4861649893132816fed4714543b9caab0185d0005ec02c9e9484ba7392a13ed90722e6beeb4ecf96e0d92cc6918a6cb343 WHIRLPOOL 2b5d276ce1843d2627f506902137945ec45f7be313538c5da48367ab4f523dec59aec5eedb2961446b967e67460eaa7f741f7f806485e4c40bac8b55012fd275
+DIST hibernate-script-2.0.tar.gz 84453 SHA256 d04597473a50c6ac072e3a4c22f173a7234a97bc2a39e460e56c5d3d985a6545 SHA512 625efdf8bd8561dd9ab93c09436f2fb93edef2fbb0fb2d259727bacffab0b7bd4a6c99d445131390883be75658f6dd28f329fdaf4f03a7d218c0021223ac1a1e WHIRLPOOL 8dab0108063b0d74d49fd075fdba7c96db7eeb8ebab5054329578b3dfe7adeb0d048db6cedfc238ba374bfa97d689eb8e08eb270ab72d861904487b7dc04dc21
diff --git a/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch b/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch
new file mode 100644
index 000000000000..bd82587336c1
--- /dev/null
+++ b/sys-power/hibernate-script/files/hibernate-script-2.0-init.d.patch
@@ -0,0 +1,56 @@
+diff -Nru hibernate-script-2.0.vanilla/init.d/hibernate-cleanup.sh hibernate-script-2.0/init.d/hibernate-cleanup.sh
+--- hibernate-script-2.0.vanilla/init.d/hibernate-cleanup.sh 2009-05-01 23:03:41.000000000 +0100
++++ hibernate-script-2.0/init.d/hibernate-cleanup.sh 2009-05-01 23:03:55.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/sbin/runscript
+
+ # This script invalidates any stale swsusp and TuxOnIce images. It
+ # searches all swap partitions on your machine, as well as TuxOnIce's
+@@ -91,27 +91,30 @@
+
+
+ msg_status() {
+- echo -n "$1"
++ einfon "$1"
+ }
+
+ msg() {
+- echo "$1"
++ einfo "$1"
+ }
+
+-case "$1" in
+-start)
+- msg_status "Invalidating stale software suspend images... "
++opts="reload"
++
++depend() {
++ after modules
++ before localmount
++}
++
++start() {
++ ebegin "Invalidating stale software suspend images"
+ do_start
+- msg "done."
+- ;;
+-stop)
++ eend $?
++}
++
++stop() {
+ do_stop
+- ;;
+-restart|force-reload)
+- do_reload
+- ;;
+-*)
+- msg "Usage: /etc/init.d/hibernate {start|stop|restart|force-reload}"
+-esac
++}
+
+-exit 0
++reload() {
++ do_reload
++}
diff --git a/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
new file mode 100644
index 000000000000..5e8cc089a76d
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+PATCH_VERSION="4"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+DOCS=( CHANGELOG README SCRIPTLET-API hibernate.vim )
+
+src_prepare() {
+ epatch "${WORKDIR}/${PV}/"*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc ${DOCS[@]}
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ chmod 644 \
+ "${D}/etc/hibernate/"*.conf \
+ "${D}/etc/hibernate/blacklisted-modules" \
+ "${D}/usr/share/hibernate/scriptlets.d/"* \
+ "${D}/usr/share/hibernate/tuxonice-binary-signature.bin" \
+ || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}
diff --git a/sys-power/hibernate-script/metadata.xml b/sys-power/hibernate-script/metadata.xml
new file mode 100644
index 000000000000..7f679d64a788
--- /dev/null
+++ b/sys-power/hibernate-script/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alonbl@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>