summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/suspend/files/suspend-1.0-bzip2.patch')
-rw-r--r--sys-power/suspend/files/suspend-1.0-bzip2.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-power/suspend/files/suspend-1.0-bzip2.patch b/sys-power/suspend/files/suspend-1.0-bzip2.patch
new file mode 100644
index 000000000000..abe5afab819b
--- /dev/null
+++ b/sys-power/suspend/files/suspend-1.0-bzip2.patch
@@ -0,0 +1,37 @@
+--- a/Makefile.am 2011-03-07 00:24:15.000000000 +0100
++++ b/Makefile.am 2012-05-22 10:52:49.023010001 +0200
+@@ -171,7 +171,8 @@
+ fbsplash_funcs.c \
+ fbsplash-test.c
+ fbsplash_test_LDADD=\
+- $(FBSPLASH_LIBS)
++ $(FBSPLASH_LIBS) \
++ $(BZ2_LIBS)
+
+ whitelist.c: whitelist.csv
+ $(PERL) wlcsv2c.pl whitelist.csv whitelist.c
+--- a/configure.ac 2011-03-07 00:24:15.000000000 +0100
++++ b/configure.ac 2012-05-22 10:52:37.918148832 +0200
+@@ -74,6 +74,22 @@
+ ,
+ [enable_fbsplash="no"]
+ )
++BZ2_LIBS=
++AS_IF(
++ [test "x${fbsplash}" = "xyes"],
++ [
++ PKG_CHECK_MODULES(
++ [FREETYPE2],
++ [freetype2],
++ ,
++ [AC_MSG_ERROR([freetype was not found.])]
++ )
++ AC_CHECK_LIB([bz2], [BZ2_bzDecompress],
++ [BZ2_LIBS="${BZ2_LIBS} -lbz2"],
++ [AC_MSG_ERROR(['libbz2' library was not found.])]
++ )
++ ]
++)
+ AC_ARG_WITH(
+ [devdir],
+ [AC_HELP_STRING([--with-devdir=DIR], [use if --enable-create-device, put devices in this directory, default /dev])],