summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild')
-rw-r--r--sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild b/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
index 65fd527c014e..3f3d74cd3f2b 100644
--- a/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
+++ b/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-inherit base bsdmk
+EAPI=5
+inherit bsdmk
DESCRIPTION="pidof(1) utility for *BSD"
HOMEPAGE="http://people.freebsd.org/~novel/pidof.html"
@@ -21,7 +22,11 @@ S="${WORKDIR}/pidof"
PATCHES=( "${FILESDIR}/${P}-gfbsd.patch"
"${FILESDIR}/${P}-firstarg.patch"
"${FILESDIR}/${P}-pname.patch"
- "${FILESDIR}/${P}-fbsd10.patch" )
+ "${FILESDIR}/${P}-fbsd11.patch" )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
src_install() {
into /