summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/prewikka/prewikka-3.0.0-r1.ebuild')
-rw-r--r--www-apps/prewikka/prewikka-3.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/prewikka/prewikka-3.0.0-r1.ebuild b/www-apps/prewikka/prewikka-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..772cd700e75d
--- /dev/null
+++ b/www-apps/prewikka/prewikka-3.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Graphical front-end analysis console for the Prelude Framework"
+HOMEPAGE="https://www.prelude-siem.org"
+SRC_URI="https://www.prelude-siem.org/pkg/src/3.0.0/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="adns"
+
+DEPEND="dev-python/setuptools
+ dev-python/lesscpy
+ sys-devel/gettext"
+
+RDEPEND="dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ adns? ( dev-python/twisted-names[${PYTHON_USEDEP}] )
+ media-fonts/font-xfree86-type1
+ dev-libs/libprelude[python,${PYTHON_USEDEP}]
+ dev-libs/libpreludedb[python,${PYTHON_USEDEP}]"