summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.21.11.ebuild147
-rw-r--r--www-apps/gitea/gitea-1.22.2.ebuild150
3 files changed, 0 insertions, 299 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index d5abce2e177d..ac0b9e564067 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1 @@
-DIST gitea-1.21.11.tar.gz 54029294 BLAKE2B 93fb0ea4118baefeb36283b7168759d318fede528b56a9167961763267181bb283bf9849ce5f57a9950b16047f3b98998b4cd0e92443a23aef4cf15589cc8628 SHA512 ba35d1710bc03ff05bf2490e233bf3b4bd9e002113885b4d2a3193288773c16ad0f2426d4ed64d26b7c49112a02838e67da32167f51c4c08fa4f23738bd78285
-DIST gitea-1.22.2.tar.gz 54444512 BLAKE2B 3e7208bf5b0273cc5394d2ceb680a28562a33ac0fea0411aac73a2d9815dab44c4fa4e76e253bbeb2862064dbd37bf04bc9b9aa85dd75be8b65ffaec0b82420a SHA512 64a84cc116877fffbf10f3f670884898221e3ae0ccc4dcfa0e661f9c0ec19ca415bd6815fde729b49eaf9653665170d6de5fe8a4ba62e85006c8c45f591bd586
DIST gitea-1.22.3.tar.gz 54325752 BLAKE2B e556dab98ea210e6bd6106addd7a019b380ffa624010eb095f5042fbf060febc8769192532a3d3506160e9d447a9e7831dbcb8fed87e6e4ecea169cbc3382c75 SHA512 a659c6eb70c01b8776e4533bca8b55bf3a4f276b43564323946076297f7f12486c0f7f872d835dcbaad62b7f79847c42c922db566f156db23f5c33140e46c39e
diff --git a/www-apps/gitea/gitea-1.21.11.ebuild b/www-apps/gitea/gitea-1.21.11.ebuild
deleted file mode 100644
index df7f876a0823..000000000000
--- a/www-apps/gitea/gitea-1.21.11.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 2016-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
-else
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv ~x86"
-fi
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-BDEPEND=">=dev-lang/go-1.21:="
-
-DOCS=(
- custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags
- local -a gitea_settings makeenv
-
- # The space-separated list of the -tags flag is deprecated, please
- # always use the comma-separated list in the future.
- gitea_tags="bindata"
- gitea_tags+="$(usex pam ',pam' '')"
- gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
-
- gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
-
- makeenv=(
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags}"
- )
-
- if [[ ${PV} != *9999 ]]; then
- # Use variable STORED_VERSION_FILE (the "${S}/VERSION" file) to set version,
- # and prevent executing git command when it's not a live version.
- makeenv+=( GITHUB_REF_NAME="" )
- fi
-
- if use pie ; then
- # Please check the supported platforms when a new keyword request opened,
- # refer to file: 'go/src/internal/platform/supported.go'.
- # When PIE buildmode is not supported by internal linker, the external
- # linker will be used automatically, refer to:
- # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
- makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
- fi
-
- env "${makeenv[@]}" emake backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
- # but for convenience, the tmpfile uses the git user and group by default.
- # To avoid installation errors, a condition needs to be added here:
- # if there is no git user or group, the installation of tmpfile will be skipped
- # and the user will be notified to handle it by themselves.
- if egetent passwd git &>/dev/null && \
- egetent group git &>/dev/null; then
- tmpfiles_process gitea.conf
- else
- eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
- eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
- eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
- eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
- eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
- eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
- eerror "to install it."
- fi
-
- if [[ -n ${REPLACING_VERSIONS} ]] && ver_test "${REPLACING_VERSIONS}" -lt 1.21; then
- ewarn "Since 1.21.0:"
- ewarn " 1. The built-in SSH server will now only accept SSH user"
- ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
- ewarn " 2. The options of the subcommand must follow the subcommand now."
- ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
- fi
-}
diff --git a/www-apps/gitea/gitea-1.22.2.ebuild b/www-apps/gitea/gitea-1.22.2.ebuild
deleted file mode 100644
index dd49814314cb..000000000000
--- a/www-apps/gitea/gitea-1.22.2.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 2016-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
-
-SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-src-${PV}"
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
-IUSE="+acct gogit pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- !gogit? ( dev-vcs/git )"
-BDEPEND=">=dev-lang/go-1.22:="
-
-DOCS=(
- custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags
- local -a gitea_settings makeenv
-
- # The space-separated list of the -tags flag is deprecated, please
- # always use the comma-separated list in the future.
- gitea_tags="bindata"
- gitea_tags+="$(usex gogit ',gogit' '')"
- gitea_tags+="$(usex pam ',pam' '')"
- gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
-
- gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
-
- makeenv=(
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags}"
- )
-
- if use pie ; then
- # Please check the supported platforms when a new keyword request opened,
- # refer to file: 'go/src/internal/platform/supported.go'.
- # When PIE buildmode is not supported by internal linker, the external
- # linker will be used automatically, refer to:
- # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
- makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
- fi
-
- env "${makeenv[@]}" emake backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
- # but for convenience, the tmpfile uses the git user and group by default.
- # To avoid installation errors, a condition needs to be added here:
- # if there is no git user or group, the installation of tmpfile will be skipped
- # and the user will be notified to handle it by themselves.
- if egetent passwd git &>/dev/null && \
- egetent group git &>/dev/null; then
- tmpfiles_process gitea.conf
- else
- eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
- eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
- eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
- eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
- eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
- eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
- eerror "to install it."
- fi
-
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- if ver_test "${REPLACING_VERSIONS}" -lt 1.21; then
- ewarn "Since version 1.21.0:"
- ewarn " 1. The built-in SSH server will now only accept SSH user"
- ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
- ewarn " 2. The options of the subcommand must follow the subcommand now."
- ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
- fi
- if ver_test "${REPLACING_VERSIONS}" -lt 1.22; then
- ewarn "Since version 1.22.0:"
- ewarn " 1. Minimum database requirements updated to MySQL 8.0, PostgreSQL 12, and MSSQL 2012."
- ewarn " 2. There are a lot of refactoring changes related to customizing templates."
- ewarn " 3. The default duration of the 'Remember login' feature has been"
- ewarn " changed from one week to one month."
- ewarn " 4. Enhanced auth token/remember me, the obsolete setting"
- ewarn " '[security].COOKIE_USERNAME' has been removed."
- ewarn " 5. For MinIO storage, adds a prefix path for all MinIO storage"
- ewarn " and override base path will override the path."
- ewarn " 6. Now use a more restricted sanitizer for the repository description."
- ewarn "For more details, see <https://github.com/go-gitea/gitea/releases/tag/v1.22.0>."
- fi
- fi
-}