summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/buku')
-rw-r--r--www-misc/buku/buku-4.6-r1.ebuild (renamed from www-misc/buku/buku-4.6.ebuild)9
1 files changed, 2 insertions, 7 deletions
diff --git a/www-misc/buku/buku-4.6.ebuild b/www-misc/buku/buku-4.6-r1.ebuild
index d7dd628bd781..27a0923bc31d 100644
--- a/www-misc/buku/buku-4.6.ebuild
+++ b/www-misc/buku/buku-4.6-r1.ebuild
@@ -3,9 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit bash-completion-r1 distutils-r1
@@ -37,10 +36,6 @@ DEPEND="${RDEPEND}
)
"
-PATCHES=(
- #"${FILESDIR}/${P}-hypothesis-fix.patch"
-)
-
python_prepare_all() {
# Remove support for bukuserver - complex depgraph which isn't all
# sufficiently packaged in Gentoo
@@ -91,5 +86,5 @@ python_test() {
)
# tests/test_server.py is bukuserver tests, ignore it
- pytest -v --ignore tests/test_server.py ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
+ pytest -p no:verbose-parametrize -v --ignore tests/test_server.py ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
}