summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild
index 652983159251..4b35ed9fa958 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-450.102.04-r1.ebuild
@@ -4,8 +4,8 @@
EAPI=7
MODULES_OPTIONAL_USE="driver"
-inherit desktop linux-info linux-mod multilib-build \
- optfeature systemd toolchain-funcs unpacker
+inherit desktop linux-info linux-mod multilib-build optfeature \
+ readme.gentoo-r1 systemd toolchain-funcs unpacker
NV_KERNEL_MAX="5.10"
NV_BIN_URI="https://download.nvidia.com/XFree86/Linux-"
@@ -81,6 +81,13 @@ DOCS=(
)
HTML_DOCS=( html/. )
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Users should be in the 'video' group to use NVIDIA devices.
+You can add yourself by using: gpasswd -a my-user video
+
+For general information on using nvidia-drivers, please see:
+https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
+
pkg_setup() {
use driver || return
@@ -341,6 +348,7 @@ src_install() {
systemd_dounit nvidia-{hibernate,resume,suspend}.service
einstalldocs
+ readme.gentoo_create_doc
}
pkg_preinst() {
@@ -371,17 +379,18 @@ pkg_preinst() {
pkg_postinst() {
use driver && linux-mod_pkg_postinst
+ readme.gentoo_print_elog
+
optfeature "wayland EGLStream with nvidia-drm.modeset=1" gui-libs/egl-wayland
if [[ -r /proc/driver/nvidia/version &&
$(grep -o ' [0-9.]* ' /proc/driver/nvidia/version) != " ${PV} " ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and will lead to GPU-using application issues."
- use driver && ewarn "The easiest way to fix this is to reboot."
+ use driver && ewarn "The easiest way to fix this is usually to reboot."
fi
if [[ ${NV_LEGACY_MASK} ]]; then
- ewarn "***** WARNING *****"
ewarn "You are installing a version of nvidia-drivers known not to work"
ewarn "with a GPU of the current system. If unwanted, add the mask:"
if [[ -d ${EROOT}/etc/portage/package.mask ]]; then
@@ -392,15 +401,4 @@ pkg_postinst() {
ewarn "...then downgrade to a legacy branch if possible. For details, see:"
ewarn "https://www.nvidia.com/object/IO_32667.html"
fi
-
- if ! [[ ${REPLACING_VERSIONS} && $(getent group video | cut -d: -f4) ]]; then
- elog "***** WARNING *****"
- elog "Users should be in the 'video' group to use NVIDIA devices."
- elog "You can add yourself by using: gpasswd -a myuser video"
- fi
-
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "For general information with using NVIDIA on Gentoo, please see:"
- elog "https://wiki.gentoo.org/wiki/NVIDIA/nvidia-drivers"
- fi
}