summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-theme-switch')
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..6d5394a73d22
--- /dev/null
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to switch and preview GTK+ theme"
+HOMEPAGE="https://packages.qa.debian.org/g/gtk-theme-switch.html"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:${GCC}:$(CC) $(LDFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ newbin ${PN}2 ${PN}
+ newman ${PN}2.1 ${PN}.1
+ dodoc ChangeLog readme todo
+}