summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild')
-rw-r--r--x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
new file mode 100644
index 000000000000..1651b6a9e6b6
--- /dev/null
+++ b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator autotools eutils
+
+DESCRIPTION="The Matchbox Desktop"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="debug dnotify startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ startup-notification? ( x11-libs/startup-notification )"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-common"
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack"
+ cd "${S}" || die
+ epatch "${FILESDIR}/${P}-dlopen.patch" || die "Patch failed"
+ eautoreconf || die
+}
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable startup-notification) \
+ $(use_enable dnotify) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}