summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 02:10:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 02:10:46 +0000
commit108e1b899b7bc9dd1bf288b0e02f62037c6a1a07 (patch)
treeec2b83ac3bfea77dfc593499f1e815599c46b963
parentadd KEYWORDS to help iproute2 (diff)
downloadhistorical-108e1b899b7bc9dd1bf288b0e02f62037c6a1a07.tar.gz
historical-108e1b899b7bc9dd1bf288b0e02f62037c6a1a07.tar.bz2
historical-108e1b899b7bc9dd1bf288b0e02f62037c6a1a07.zip
add patch for sjlj exceptions and arm
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r10.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r10.ebuild b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
index 428d843571b7..a15247fc4a29 100644
--- a/sys-libs/glibc/glibc-2.3.2-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.7 2004/04/26 02:07:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.8 2004/04/27 02:10:46 vapier Exp $
IUSE="nls pic build nptl"
@@ -410,6 +410,14 @@ src_unpack() {
cd ${S}/sysdeps/unix/sysv/linux; epatch ${FILESDIR}/2.3.2/${P}-s390-deprecated-ustat-fixup.patch
fi
+ if [ "${ARCH}" == "arm" ]
+ then
+ # sjlj exceptions can cause issues with undefined frame variables.
+ # this patch has been ported from current glibc cvs.
+ cd ${S}/sysdeps/generic
+ epatch ${FILESDIR}/glibc-framestate-USING_SJLJ_EXCEPTIONS.patch
+ fi
+
# Fix permissions on some of the scripts
chmod u+x ${S}/scripts/*.sh
}