summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-29 08:08:19 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-29 08:08:19 +0000
commit20a70ba464f8377de7305b5dc6c73219f0cff907 (patch)
tree36977db909c46b35eb69525ffe698625f81bdd40
parentDisable the --add-needed sed I was using for testing. (diff)
downloadhistorical-20a70ba464f8377de7305b5dc6c73219f0cff907.tar.gz
historical-20a70ba464f8377de7305b5dc6c73219f0cff907.tar.bz2
historical-20a70ba464f8377de7305b5dc6c73219f0cff907.zip
Version bumped.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
-rw-r--r--app-i18n/ibus-pinyin/ChangeLog7
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.3.7.ebuild55
-rw-r--r--app-i18n/ibus/ChangeLog7
-rw-r--r--app-i18n/ibus/ibus-1.3.4.ebuild112
4 files changed, 179 insertions, 2 deletions
diff --git a/app-i18n/ibus-pinyin/ChangeLog b/app-i18n/ibus-pinyin/ChangeLog
index 88b47e87f7d6..00a18709a0bf 100644
--- a/app-i18n/ibus-pinyin/ChangeLog
+++ b/app-i18n/ibus-pinyin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-pinyin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.23 2010/05/26 10:36:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ChangeLog,v 1.24 2010/05/29 08:08:19 matsuu Exp $
+
+*ibus-pinyin-1.3.7 (29 May 2010)
+
+ 29 May 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-pinyin-1.3.7.ebuild:
+ Version bumped.
26 May 2010; Pacho Ramos <pacho@gentoo.org>
ibus-pinyin-1.2.0.20090915.ebuild:
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.3.7.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.7.ebuild
new file mode 100644
index 000000000000..1988d25246ec
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.3.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-pinyin/ibus-pinyin-1.3.7.ebuild,v 1.1 2010/05/29 08:08:19 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="sqlite"
+inherit python
+
+PYDB_TAR="pinyin-database-1.2.99.tar.bz2"
+DESCRIPTION="Chinese PinYin IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz
+ http://ibus.googlecode.com/files/${PYDB_TAR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ >=dev-libs/boost-1.39
+ sys-apps/util-linux
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ cp "${DISTDIR}/${PYDB_TAR}" "${S}"/data/db/open-phrase/ || die
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) --enable-db-open-phrase || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 14b6768f8dbb..2b3716168ec6 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.61 2010/05/14 16:43:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.62 2010/05/29 08:06:21 matsuu Exp $
+
+*ibus-1.3.4 (29 May 2010)
+
+ 29 May 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-1.3.4.ebuild:
+ Version bumped.
*ibus-1.3.3-r2 (14 May 2010)
diff --git a/app-i18n/ibus/ibus-1.3.4.ebuild b/app-i18n/ibus/ibus-1.3.4.ebuild
new file mode 100644
index 000000000000..912f7c481049
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.3.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.3.4.ebuild,v 1.1 2010/05/29 08:06:21 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.5"
+inherit eutils gnome2-utils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +gconf nls +python"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2
+ gconf? ( >=gnome-base/gconf-2.12 )
+ >=gnome-base/librsvg-2
+ sys-apps/dbus
+ app-text/iso-codes
+ x11-libs/libX11
+ python? (
+ dev-python/notify-python
+ >=dev-python/dbus-python-0.83
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ python? (
+ dev-python/pygtk
+ dev-python/pyxdg
+ )"
+
+RESTRICT="test"
+
+update_gtk_immodules() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ GTK2_CONFDIR="/etc/gtk-2.0"
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="${GTK2_CONFDIR}/${CHOST}"
+ mkdir -p "${ROOT}${GTK2_CONFDIR}"
+ gtk-query-immodules-2.0 > "${ROOT}${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ echo "ibus/_config.py" >> po/POTFILES.skip || die
+ sed -i -e "s/python/python2/" setup/ibus-setup.in ui/gtk/ibus-ui-gtk.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable gconf) \
+ $(use_enable nls) \
+ $(use_enable python) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # bug 289547
+ keepdir /usr/share/ibus/{engine,icons} || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog
+ elog "2. Setup ibus:"
+ elog
+ elog " $ ibus-setup"
+ elog
+ elog "3. Set the following in your user startup scripts"
+ elog " such as .xinitrc, .xsession or .xprofile:"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"xim\""
+ elog " ibus-daemon -d -x"
+
+ update_gtk_immodules
+
+ use python && python_mod_optimize /usr/share/${PN}
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ update_gtk_immodules
+
+ use python && python_mod_cleanup /usr/share/${PN}
+ gnome2_icon_cache_update
+}