summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-31 06:10:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-31 06:10:03 +0000
commit24910d3bd206ee88964e4a6e6b3141cb468e6a8f (patch)
treea15f5f6d7565e8824ecc61ff3f0ed93345d7d4cd
parentBump for Rails 2.3.8. Drop hppa/ppc/ppc64/x86-fbsd keywords due to new unkeyw... (diff)
downloadhistorical-24910d3bd206ee88964e4a6e6b3141cb468e6a8f.tar.gz
historical-24910d3bd206ee88964e4a6e6b3141cb468e6a8f.tar.bz2
historical-24910d3bd206ee88964e4a6e6b3141cb468e6a8f.zip
Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded dependency.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
-rw-r--r--dev-ruby/actionmailer/ChangeLog9
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.8.ebuild32
-rw-r--r--dev-ruby/actionpack/ChangeLog8
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.8.ebuild41
-rw-r--r--dev-ruby/activerecord/ChangeLog9
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.8.ebuild52
-rw-r--r--dev-ruby/activeresource/ChangeLog9
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.8.ebuild28
-rw-r--r--dev-ruby/rails/ChangeLog8
-rw-r--r--dev-ruby/rails/rails-2.3.8.ebuild80
10 files changed, 271 insertions, 5 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index ff5980aa0136..2816722de0cc 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.141 2010/05/23 11:01:12 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.142 2010/05/31 06:01:48 graaff Exp $
+
+*actionmailer-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> actionmailer-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.8.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.8.ebuild
new file mode 100644
index 000000000000..be83634e23e9
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.8.ebuild,v 1.1 2010/05/31 06:01:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 319c3330930e..737a9032d638 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.153 2010/05/23 10:49:20 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.154 2010/05/31 05:59:53 graaff Exp $
+
+*actionpack-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> actionpack-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/actionpack/actionpack-2.3.8.ebuild b/dev-ruby/actionpack/actionpack-2.3.8.ebuild
new file mode 100644
index 000000000000..128d548904b3
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.8.ebuild,v 1.1 2010/05/31 05:59:53 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-1.1.0"
+
+ruby_add_bdepend test "dev-ruby/activerecord:${SLOT} dev-ruby/actionmailer:${SLOT}"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # This tries to load a “vendorized” copy of activerecord that we
+ # will never have.
+ sed -i -e '/PATH_TO_AR/s:^:#:' test/active_record_unit.rb || die
+
+ # Fix the testsuite, the symlink is not present in the gem for
+ # some reason
+ ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+}
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index a6418a5aca1e..e706221f9a92 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.134 2010/05/23 10:37:02 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.135 2010/05/31 06:07:54 graaff Exp $
+
+*activerecord-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> activerecord-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/activerecord/activerecord-2.3.8.ebuild b/dev-ruby/activerecord/activerecord-2.3.8.ebuild
new file mode 100644
index 000000000000..89b96af3628a
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.8.ebuild,v 1.1 2010/05/31 06:07:54 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 sqlite3" "dev-ruby/sqlite3-ruby"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 mysql" ">=dev-ruby/mysql-ruby-2.7"
+USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 postgres" "dev-ruby/pg"
+
+ruby_add_bdepend test ">=dev-ruby/mocha-0.9.5 virtual/ruby-test-unit"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+#
+# if use sqlite; then
+# ${RUBY} -S rake test_sqlite || die "sqlite3 tests failed"
+# fi
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 1aa7fd70c676..af4ec42b4fd9 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.63 2010/05/23 10:40:04 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.64 2010/05/31 06:06:14 graaff Exp $
+
+*activeresource-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
23 May 2010; Alex Legler <a3li@gentoo.org> activeresource-2.3.5-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/activeresource/activeresource-2.3.8.ebuild b/dev-ruby/activeresource/activeresource-2.3.8.ebuild
new file mode 100644
index 000000000000..1b4a775cce75
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.8.ebuild,v 1.1 2010/05/31 06:06:14 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend test ">=dev-ruby/mocha-0.9.5 virtual/ruby-test-unit"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index fb0868f0e858..62aca89677d1 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.174 2010/05/23 11:03:14 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.175 2010/05/31 06:10:03 graaff Exp $
+
+*rails-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
*rails-2.3.5-r3 (23 May 2010)
diff --git a/dev-ruby/rails/rails-2.3.8.ebuild b/dev-ruby/rails/rails-2.3.8.ebuild
new file mode 100644
index 000000000000..67bd6d0ab34d
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.8.ebuild,v 1.1 2010/05/31 06:10:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ # fails for missing template when using the gem distribution
+ #if use doc; then
+ # pushd guides
+ # ruby rails_guides.rb || die "guide generation failed"
+ # popd
+ #fi
+}
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ #pushd guides/output
+ #docinto guides
+ #dohtml -r *
+ #popd
+
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}