summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-11-06 17:30:01 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-11-06 17:30:01 +0000
commit26ee81511bc3057f4acbcce31cd3a20e96744285 (patch)
treee89c506020c4c5d5170bbc09a211f07dc562edf5
parentFinally stable on ppc, bug #69825. (diff)
downloadhistorical-26ee81511bc3057f4acbcce31cd3a20e96744285.tar.gz
historical-26ee81511bc3057f4acbcce31cd3a20e96744285.tar.bz2
historical-26ee81511bc3057f4acbcce31cd3a20e96744285.zip
Added filter-flags -invisibility-inlines-hidden bug# 68500
-rw-r--r--x11-libs/wxGTK/ChangeLog8
-rw-r--r--x11-libs/wxGTK/Manifest8
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild6
-rw-r--r--x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild6
5 files changed, 20 insertions, 14 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index e58ce16eb1aa..04c89fb7b57c 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.63 2004/09/09 01:34:08 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.64 2004/11/06 17:30:01 pythonhead Exp $
+
+*wxGTK-2.5.1-r1 (06 Nov 2004)
+
+ 06 Nov 2004; Rob Cakebread <pythonhead@gentoo.org> wxGTK-2.4.2-r2.ebuild,
+ wxGTK-2.4.2-r3.ebuild, wxGTK-2.5.1-r1.ebuild:
+ Added filter-flags -invisibility-inlines-hidden bug# 68500
08 Sep 2004; Rob Cakebread <pythonhead@gentoo.org> -wxGTK-2.5.1.ebuild:
Modified so apps can use wxwidgets eclass
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index e13f0c3c000e..53006032a5b8 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -1,8 +1,8 @@
-MD5 61ee553d68a170ee51088021bbb34ffa ChangeLog 10565
+MD5 e4886946692f9e9f468e132421bb4614 ChangeLog 10782
MD5 4fca175f747a090fd2b7b8ce22fbc06d metadata.xml 162
-MD5 42f4a920d62623e23fd772d0a49d5cfb wxGTK-2.4.2-r2.ebuild 4006
-MD5 d6d6b9099c93c0682502743e673ffb8c wxGTK-2.4.2-r3.ebuild 4159
-MD5 0ae775d0e5b1a833da1b3355dd9f2cdb wxGTK-2.5.1-r1.ebuild 3874
+MD5 2446ed5d1e5af50f34fce6d2990c7407 wxGTK-2.4.2-r2.ebuild 4065
+MD5 5cecf6db79f89a2ac64d762bddf86e1b wxGTK-2.4.2-r3.ebuild 4220
+MD5 65afbb947e86307299f467587368b11c wxGTK-2.5.1-r1.ebuild 3928
MD5 5087298be841a84071ea67830f5d6a2b files/digest-wxGTK-2.4.2-r2 65
MD5 5087298be841a84071ea67830f5d6a2b files/digest-wxGTK-2.4.2-r3 65
MD5 574b30817d120dcaf7e94832c64b003a files/wxGTK-2.4.1-contrib.patch 572
diff --git a/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild b/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild
index 009ba75c183d..2aa4ff0d70c6 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild,v 1.2 2004/08/19 02:16:32 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r2.ebuild,v 1.3 2004/11/06 17:30:01 pythonhead Exp $
-inherit eutils
+inherit flag-o-matic eutils
DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
HOMEPAGE="http://www.wxwidgets.org/"
@@ -61,7 +61,7 @@ pkg_setup() {
src_compile() {
local myconf
export LANG='C'
-
+ filter-flags -fvisibility-inlines-hidden
myconf="${myconf} `use_with opengl`"
myconf="${myconf} --with-gtk"
myconf="${myconf} `use_enable debug`"
diff --git a/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild b/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild
index a2357dbfbfa9..3fa8fafb4187 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild,v 1.1 2004/09/02 11:15:24 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r3.ebuild,v 1.2 2004/11/06 17:30:01 pythonhead Exp $
-inherit eutils
+inherit flag-o-matic eutils
DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
HOMEPAGE="http://www.wxwidgets.org/"
@@ -61,7 +61,7 @@ pkg_setup() {
src_compile() {
local myconf
export LANG='C'
-
+ filter-flags -fvisibility-inlines-hidden
myconf="${myconf} `use_with opengl`"
myconf="${myconf} --with-gtk"
myconf="${myconf} `use_enable debug`"
diff --git a/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild
index e294f0d1c634..b89472e00ec1 100644
--- a/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild,v 1.1 2004/09/09 01:34:08 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.5.1-r1.ebuild,v 1.2 2004/11/06 17:30:01 pythonhead Exp $
-inherit eutils
+inherit flag-o-matic eutils
DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit."
HOMEPAGE="http://www.wxwidgets.org/"
@@ -52,7 +52,7 @@ pkg_setup() {
src_compile() {
local myconf
export LANG='C'
-
+ filter-flags -fvisibility-inlines-hidden
myconf="${myconf} `use_with opengl`"
myconf="${myconf} --with-gtk"
myconf="${myconf} `use_enable debug`"