summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-05-15 05:37:02 +0000
committerJon Hood <squinky86@gentoo.org>2006-05-15 05:37:02 +0000
commit2d072446db30e013ba60b2a43f1592ef61383c69 (patch)
treef9f0c95c444b7257053afe561e69e73aa1173c1f
parentStable on amd64 wrt #133320. (diff)
downloadhistorical-2d072446db30e013ba60b2a43f1592ef61383c69.tar.gz
historical-2d072446db30e013ba60b2a43f1592ef61383c69.tar.bz2
historical-2d072446db30e013ba60b2a43f1592ef61383c69.zip
add new version with reported bugfixes and remove old buggy version
Package-Manager: portage-2.1_rc1-r2
-rw-r--r--net-p2p/ghostwhitecrab/ChangeLog9
-rw-r--r--net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.7.23
-rw-r--r--net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.7.2.ebuild84
3 files changed, 95 insertions, 1 deletions
diff --git a/net-p2p/ghostwhitecrab/ChangeLog b/net-p2p/ghostwhitecrab/ChangeLog
index 500accdba231..d65cd44931f8 100644
--- a/net-p2p/ghostwhitecrab/ChangeLog
+++ b/net-p2p/ghostwhitecrab/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/ghostwhitecrab
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ChangeLog,v 1.4 2006/04/26 04:10:09 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ChangeLog,v 1.5 2006/05/15 05:37:02 squinky86 Exp $
+
+*ghostwhitecrab-0.9.7.2 (15 May 2006)
+
+ 15 May 2006; Jon Hood <squinky86@gentoo.org>
+ -ghostwhitecrab-0.9.6.1.ebuild, +ghostwhitecrab-0.9.7.2.ebuild:
+ Version bump, remove buggy version in favor of one with more options and
+ less problems.
*ghostwhitecrab-0.9.6.1 (26 Apr 2006)
diff --git a/net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.7.2 b/net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.7.2
new file mode 100644
index 000000000000..0157dcbc60c3
--- /dev/null
+++ b/net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.7.2
@@ -0,0 +1,3 @@
+MD5 71ee9f56892bfe1bc06f131269095a98 gwc-0.9.7r2.tar.bz2 167041
+RMD160 de917d9dfd7ffb9d9c950e87d34544f0ef297fac gwc-0.9.7r2.tar.bz2 167041
+SHA256 d2714022541c6ba168f0ab2d8827b028debe05d8f4aae938438680c55bdef8a7 gwc-0.9.7r2.tar.bz2 167041
diff --git a/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.7.2.ebuild b/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.7.2.ebuild
new file mode 100644
index 000000000000..19bbe102875a
--- /dev/null
+++ b/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.7.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.7.2.ebuild,v 1.1 2006/05/15 05:37:02 squinky86 Exp $
+
+inherit eutils versionator
+
+IUSE="ipv6 threads zlib"
+
+MY_PV=$(replace_version_separator 3 'r' )
+MY_P="gwc-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="stand-alone gwebcache daemon"
+HOMEPAGE="http://www.ghostwhitecrab.com/crab/"
+SRC_URI="http://www.ghostwhitecrab.com/crab/${MY_P}.tar.bz2"
+LICENSE="as-is FDL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~hppa ~amd64"
+
+DEPEND=">=sys-apps/sed-4
+ sys-libs/zlib
+ virtual/libc"
+RDEPEND=""
+
+pkg_setup() {
+ enewgroup gwc
+ enewuser gwc -1 /bin/bash /dev/null gwc
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:#User:User:g' examples/example.conf
+ sed -i -e 's:#Group:Group:g' examples/example.conf
+ sed -i -e 's:~gwc/db:/usr/share/gwc:g' examples/example.conf
+ sed -i -e 's:#data_template\t\t/path/to/data_template:data_template\t\t/usr/share/gwc/data_template:g' examples/example.conf
+ sed -i -e 's:#base_template\t\t/path/to/base_template:base_template\t\t/usr/share/gwc/base_template:g' examples/example.conf
+ sed -i -e 's:#listen_address\t\t:listen_address\t\t:g' examples/example.conf
+ sed -i -e 's:~gwc/logs:/var/log/gwc:g' examples/example.conf
+ sed -i -e 's:~gwc/cores:/var/log/gwc:g' examples/example.conf
+ sed -i -e 's:sleep 1::g' config.sh
+}
+
+src_compile() {
+ # this is not a standard configure script, so can't use the standard
+ # use_* functions
+ local myconf
+ use threads && myconf="--use-threads ${myconf}"
+ use ipv6 || myconf="--disable-ipv6 ${myconf}"
+ use zlib || myconf="--disable-zlib ${myconf}"
+ ./config.sh ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin src/gwc
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ newins examples/example.conf gwc.conf
+ dodir /usr/share/gwc
+ touch ${D}/usr/share/gwc/peer_cache
+ touch ${D}/usr/share/gwc/urls.good
+ touch ${D}/usr/share/gwc/urls.bad
+ insinto /usr/share/gwc
+ newins examples/data_html.template data_template
+ newins examples/base_html.template base_template
+ chown -R gwc:gwc ${D}/usr/share/gwc
+ dodir /var/log/gwc
+ touch ${D}/var/log/gwc/main.log
+ touch ${D}/var/log/gwc/access.log
+ touch ${D}/var/log/gwc/dns.log
+ touch ${D}/var/log/gwc/checks.log
+ chown -R gwc:gwc ${D}/var/log/gwc
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gwc.init gwc
+ dohtml doc/*.html doc/*.css doc/specs/*.html
+ dodoc doc/specs/*.txt examples/*
+}
+
+pkg_postinst() {
+ einfo "Please set the \"Location\" of your cache in /etc/${PN}/gwc.conf"
+ einfo "and submit your cache to:"
+ einfo "\thttp://gcachescan.jonatkins.com/"
+}