summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-28 01:41:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-28 01:41:12 +0000
commit30307744e54780adf0d0f0fdd2657741601f6f85 (patch)
treedceda7952ce96ac50d1b31dc6982078033be708b
parentforgot to add the changelog into CVS (diff)
downloadhistorical-30307744e54780adf0d0f0fdd2657741601f6f85.tar.gz
historical-30307744e54780adf0d0f0fdd2657741601f6f85.tar.bz2
historical-30307744e54780adf0d0f0fdd2657741601f6f85.zip
man page/LFH fixes.
-rw-r--r--app-emulation/wine/ChangeLog12
-rw-r--r--app-emulation/wine/wine-20020310.ebuild16
2 files changed, 20 insertions, 8 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index a7b13eb19de2..a07a231c1bdf 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.4 2002/03/22 17:19:46 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.5 2002/03/28 01:41:12 seemant Exp $
- 22 Mar 2002; Dan Armak <danarmak@gentoo.org> Add missing /etc/wine/winedefault.reg file.
+
+*wine-20020310 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> wine-20020310.ebuild :
+
+ man page/LFH fix submitted by Matthew Kennedy.
+
+
+22 Mar 2002; Dan Armak <danarmak@gentoo.org> Add missing /etc/wine/winedefault.reg file.
*wine-20020310 (12 Mar 2002)
diff --git a/app-emulation/wine/wine-20020310.ebuild b/app-emulation/wine/wine-20020310.ebuild
index 8615318db90b..4510cde67576 100644
--- a/app-emulation/wine/wine-20020310.ebuild
+++ b/app-emulation/wine/wine-20020310.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020310.ebuild,v 1.2 2002/03/22 17:19:46 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020310.ebuild,v 1.3 2002/03/28 01:41:12 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Wine is a free implementation of Windows on Unix."
@@ -28,8 +28,12 @@ src_compile() {
[ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
# there's no configure flag for cups, it's supposed to be autodetected
- ./configure --prefix=/usr --sysconfdir=/etc/wine \
- --host=${CHOST} --enable-curses ${myconf} || die
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
cd ${S}/programs/winetest
cp Makefile 1
@@ -44,9 +48,9 @@ src_compile() {
src_install () {
cd ${S}
- make prefix=${D}/usr install || die
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
cd ${S}/programs
- make prefix=${D}/usr install || die
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
# these .so's are strange. they are from the make in programs/ above,
# and are for apps built with winelib (windows sources built directly