summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2006-02-17 19:27:34 +0000
committerJohn Mylchreest <johnm@gentoo.org>2006-02-17 19:27:34 +0000
commit366fcb3e7e5269bb9e634883efe66a83f92139f8 (patch)
tree6e035437d8b4d8c35a644103f346d6adbcea3ee3
parentversion bump. (diff)
downloadhistorical-366fcb3e7e5269bb9e634883efe66a83f92139f8.tar.gz
historical-366fcb3e7e5269bb9e634883efe66a83f92139f8.tar.bz2
historical-366fcb3e7e5269bb9e634883efe66a83f92139f8.zip
Initial import. Also closes bug #98335
Package-Manager: portage-2.1_pre4-r1
-rw-r--r--media-sound/monopod/ChangeLog10
-rw-r--r--media-sound/monopod/metadata.xml14
-rw-r--r--media-sound/monopod/monopod-0.3.ebuild32
3 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/monopod/ChangeLog b/media-sound/monopod/ChangeLog
new file mode 100644
index 000000000000..ffe1f7cd2dae
--- /dev/null
+++ b/media-sound/monopod/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/monopod
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/monopod/ChangeLog,v 1.1 2006/02/17 19:27:34 johnm Exp $
+
+*monopod-0.3 (17 Feb 2006)
+
+ 17 Feb 2006; John Mylchreest <johnm@gentoo.org> +metadata.xml,
+ +monopod-0.3.ebuild:
+ initial import. Also closes bug #98335.
+
diff --git a/media-sound/monopod/metadata.xml b/media-sound/monopod/metadata.xml
new file mode 100644
index 000000000000..dbd65e196d3f
--- /dev/null
+++ b/media-sound/monopod/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>johnm@gentoo.org</email>
+ <name>John Mylchreest</name>
+ </maintainer>
+ <longdescription lang="en">
+ Monopod is a very simplistic Podcast client with planned iPod support
+ written in GTK#. It's to the point, without the bloat.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/media-sound/monopod/monopod-0.3.ebuild b/media-sound/monopod/monopod-0.3.ebuild
new file mode 100644
index 000000000000..6597b40c25dd
--- /dev/null
+++ b/media-sound/monopod/monopod-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/monopod/monopod-0.3.ebuild,v 1.1 2006/02/17 19:27:34 johnm Exp $
+
+inherit gnome2 mono
+
+DESCRIPTION="A very lightweight podcast client in GTK#"
+HOMEPAGE="http://downloads.usefulinc.com/monopod/"
+SRC_URI="http://downloads.usefulinc.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-lang/mono-1.1.6
+ >=dev-dotnet/glade-sharp-1.9.5
+ >=dev-dotnet/gconf-sharp-2.0
+ >=dev-dotnet/gtk-sharp-1.9.5
+ >=dev-dotnet/gnome-sharp-1.9.5
+ dev-db/sqlite"
+
+USE_DESTDIR=1
+DOCS="ChangeLog NEWS README TODO AUTHORS"
+
+src_compile() {
+ gnome2_src_configure
+ emake -j1 || "make failed"
+}
+
+src_install() {
+ gnome2_src_install
+}