summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-11-28 13:17:08 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-11-28 13:17:08 +0000
commit41a17ea68f1bb670979bd6b5a6755e5d7c17df59 (patch)
tree5aecefbf8b5c9e6510c93556dd852df21f6e1dda
parentAdd a missing RDEPEND. Closes #72653. (diff)
downloadhistorical-41a17ea68f1bb670979bd6b5a6755e5d7c17df59.tar.gz
historical-41a17ea68f1bb670979bd6b5a6755e5d7c17df59.tar.bz2
historical-41a17ea68f1bb670979bd6b5a6755e5d7c17df59.zip
New package, as requested in bug #67261
-rw-r--r--app-vim/vimoutliner/ChangeLog10
-rw-r--r--app-vim/vimoutliner/Manifest14
-rw-r--r--app-vim/vimoutliner/files/digest-vimoutliner-0.3.31
-rw-r--r--app-vim/vimoutliner/metadata.xml9
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.3.ebuild42
5 files changed, 76 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/ChangeLog b/app-vim/vimoutliner/ChangeLog
new file mode 100644
index 000000000000..b45955a66b79
--- /dev/null
+++ b/app-vim/vimoutliner/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/vimoutliner
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/ChangeLog,v 1.1 2004/11/28 13:17:08 ciaranm Exp $
+
+*vimoutliner-0.3.3 (28 Nov 2004)
+
+ 28 Nov 2004; Ciaran McCreesh <ciaranm@gentoo.org> +metadata.xml,
+ +vimoutliner-0.3.3.ebuild:
+ New package, as requested in bug #67261
+
diff --git a/app-vim/vimoutliner/Manifest b/app-vim/vimoutliner/Manifest
new file mode 100644
index 000000000000..6aad2a2b4067
--- /dev/null
+++ b/app-vim/vimoutliner/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e338a9b89cd2128308f8144fe0714170 vimoutliner-0.3.3.ebuild 1054
+MD5 09dc2865fcfb6228ea0110d9c578ba7c ChangeLog 385
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 dff564f942c557805a4254359c428756 files/digest-vimoutliner-0.3.3 68
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBqc/OLLFUmVNQ7rkRAjKAAKDJvkmEyxJjJAQPdy8MBUTLeSqzuwCdGunq
+GTZ+nLnTr+zX6NGo3U72zm4=
+=ejkM
+-----END PGP SIGNATURE-----
diff --git a/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3 b/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3
new file mode 100644
index 000000000000..6fadd946c8ec
--- /dev/null
+++ b/app-vim/vimoutliner/files/digest-vimoutliner-0.3.3
@@ -0,0 +1 @@
+MD5 b414f69539d203e29777a5bf1aae15e9 vimoutliner-0.3.3.tar.gz 45426
diff --git a/app-vim/vimoutliner/metadata.xml b/app-vim/vimoutliner/metadata.xml
new file mode 100644
index 000000000000..3a147a175714
--- /dev/null
+++ b/app-vim/vimoutliner/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+<maintainer>
+ <email>ciaranm@gentoo.org</email>
+ <name>Ciaran McCreesh</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild
new file mode 100644
index 000000000000..457c01d1a408
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild,v 1.1 2004/11/28 13:17:08 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="http://www.vimoutliner.org"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim
+ sed -i -e '/ru .vimoutlinerrc/aru vimoutlinerrc' ftplugin/vo_base.vim
+ sed -i -e '/hi spellErr,SpellErrors,BadWord/d' syntax/vo_base.vim
+}
+
+src_install() {
+ cd ${S}
+ p=/usr/share/vim/vimfiles
+ for d in doc ftdetect ftplugin syntax ; do
+ dodir ${p}/${d}
+ cp -R ${d} ${D}/${p}/
+ done
+
+ dodir ${p}/vimoutliner/plugins
+ cp -R add-ons/plugins ${D}/${p}/vimoutliner/
+
+ for d in scripts/* add-ons/scripts/* ; do
+ dobin ${d}
+ done
+
+ dodoc vimoutlinerrc
+}
+