summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-07-13 11:52:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-07-13 11:52:09 +0000
commit49878ec404dd6edeb03686bfdef99c5bcaef6526 (patch)
tree529ac3cf5b311a79c605aa35ada4aaa3de16dcac
parentremoval (bug #321685) (diff)
downloadhistorical-49878ec404dd6edeb03686bfdef99c5bcaef6526.tar.gz
historical-49878ec404dd6edeb03686bfdef99c5bcaef6526.tar.bz2
historical-49878ec404dd6edeb03686bfdef99c5bcaef6526.zip
Initial commit. Taking ownership. Bug #258396
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
-rw-r--r--sys-devel/ct-ng/ChangeLog8
-rw-r--r--sys-devel/ct-ng/Manifest5
-rw-r--r--sys-devel/ct-ng/ct-ng-1.7.1.ebuild31
-rw-r--r--sys-devel/ct-ng/files/fix-man-path.patch13
-rw-r--r--sys-devel/ct-ng/metadata.xml18
5 files changed, 75 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
new file mode 100644
index 000000000000..6cb2e0f75804
--- /dev/null
+++ b/sys-devel/ct-ng/ChangeLog
@@ -0,0 +1,8 @@
+
+
+*ct-ng-1.7.1 (13 Jul 2010)
+
+ 13 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.7.1.ebuild,
+ +files/fix-man-path.patch, +metadata.xml:
+ Initial commit. Taking ownership. Bug #258396
+
diff --git a/sys-devel/ct-ng/Manifest b/sys-devel/ct-ng/Manifest
new file mode 100644
index 000000000000..dc34b966b736
--- /dev/null
+++ b/sys-devel/ct-ng/Manifest
@@ -0,0 +1,5 @@
+AUX fix-man-path.patch 538 RMD160 7306109b01f7e2436a5b796ecb9f5658ca7ac7e5 SHA1 2b68396893b6fde9e371e8402e2e60b8332b51d6 SHA256 29c942ad81195b5b9343fe74c4c3f6bf20354fc9bdc89edefc50c4f5d14e2fcb
+DIST crosstool-ng-1.7.1.tar.bz2 1855616 RMD160 839d1853c881668dbf6f3d8989ee6351bd3a17cb SHA1 94cf118c0d488741fcc0a29788e451a8ea4e81de SHA256 d155c37e9365838b94596a30dda821cb3087c0bbd51cd17dda1747b52055bfea
+EBUILD ct-ng-1.7.1.ebuild 811 RMD160 0e26478d283c6a925518ca7166eb2de36aeefe0d SHA1 9298b003c58c9e78824de267793f2208c8220633 SHA256 a8a134958642319d75e9cfb2a4e44a46f9552b7abaefe4791153842ae20583bb
+MISC ChangeLog 199 RMD160 725a021232e67013b66b9fc61c0c4d12588fd9a7 SHA1 a1850ce361aae712d276d1ea7fa05326848c2d0f SHA256 c64390fbd6d67e6ff7c29858e15c665361cc5d28238eda715704af5c98d6665d
+MISC metadata.xml 591 RMD160 55a2fd2072e170086cb769db7ea5f9276adb9565 SHA1 89549776dfa636d468dadc21cfbaf12cfc9cc8a2 SHA256 d34d874d1a34cc44f07204da31ec903d59f052bce2d98169d5703dacb15d9ae5
diff --git a/sys-devel/ct-ng/ct-ng-1.7.1.ebuild b/sys-devel/ct-ng/ct-ng-1.7.1.ebuild
new file mode 100644
index 000000000000..a7fae237aa8d
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.7.1.ebuild,v 1.1 2010/07/13 11:52:08 blueness Exp $
+
+EAPI="2"
+
+inherit eutils bash-completion
+
+DESCRIPTION="A tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-vcs/cvs"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-man-path.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcompletion ct-ng.comp
+ dodoc README TODO docs/known-issues.txt
+}
diff --git a/sys-devel/ct-ng/files/fix-man-path.patch b/sys-devel/ct-ng/files/fix-man-path.patch
new file mode 100644
index 000000000000..2e83565d7acd
--- /dev/null
+++ b/sys-devel/ct-ng/files/fix-man-path.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2010-06-06 12:54:45.000000000 -0400
++++ configure 2010-06-06 13:28:06.000000000 -0400
+@@ -410,6 +410,10 @@
+ [ -z "${DOCDIR_set}" ] && DOCDIR="${PREFIX}/share/doc"
+ [ -z "${MANDIR_set}" ] && MANDIR="${PREFIX}/share/man/man1"
+
++# Append man1 if a autobuild style --mandir=/usr/share/man path was given
++MANDIR=${MANDIR%/}
++MANDIR=${MANDIR/\/share\/man//share/man/man1}
++
+ # Install support files in our own sub-dir, so as not to mangle (system)
+ # files and dirs, but only if not --local
+ if [ -z "${LOCAL_set}" ]; then
diff --git a/sys-devel/ct-ng/metadata.xml b/sys-devel/ct-ng/metadata.xml
new file mode 100644
index 000000000000..9e91abd4019b
--- /dev/null
+++ b/sys-devel/ct-ng/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription lang="en">
+ crosstool-NG is a utility for building cross-compiling toolchains.
+ It will only build the toolchain. It is up to use how you want to
+ use it after that.
+
+ It is an alternative to sys-devel/crossdev.
+
+ For more information, see http://ymorin.is-a-geek.org/projects/crosstool
+ </longdescription>
+</pkgmetadata>