summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-22 07:55:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-22 07:55:34 +0000
commit4cadc7a02175ac66b93ba2408d279e9b844ef00c (patch)
tree8300b4c78e056340ef4a6b5969fc98120c6e5b81
parentMarked stable on mips. (diff)
downloadhistorical-4cadc7a02175ac66b93ba2408d279e9b844ef00c.tar.gz
historical-4cadc7a02175ac66b93ba2408d279e9b844ef00c.tar.bz2
historical-4cadc7a02175ac66b93ba2408d279e9b844ef00c.zip
initial commit - ebuild based on the one provided by David Ranvig via bug #54459
-rw-r--r--games-action/xblast/ChangeLog11
-rw-r--r--games-action/xblast/Manifest4
-rw-r--r--games-action/xblast/files/digest-xblast-2.9.221
-rw-r--r--games-action/xblast/metadata.xml5
-rw-r--r--games-action/xblast/xblast-2.9.22.ebuild35
5 files changed, 56 insertions, 0 deletions
diff --git a/games-action/xblast/ChangeLog b/games-action/xblast/ChangeLog
new file mode 100644
index 000000000000..e652e72c2d23
--- /dev/null
+++ b/games-action/xblast/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-action/xblast
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/ChangeLog,v 1.1 2004/09/22 07:55:34 mr_bones_ Exp $
+
+*xblast-2.9.22 (22 Sep 2004)
+
+ 22 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +xblast-2.9.22.ebuild:
+ initial commit - ebuild based on the one provided by David Ranvig via bug
+ #54459
+
diff --git a/games-action/xblast/Manifest b/games-action/xblast/Manifest
new file mode 100644
index 000000000000..95e1f7ffd889
--- /dev/null
+++ b/games-action/xblast/Manifest
@@ -0,0 +1,4 @@
+MD5 c09b7e9258e9b0969bff06313231c76d xblast-2.9.22.ebuild 937
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 fccaa5e89e4b733de674f6a3351b66b5 ChangeLog 425
+MD5 1653fa4c893840b332f23aae69809ce8 files/digest-xblast-2.9.22 66
diff --git a/games-action/xblast/files/digest-xblast-2.9.22 b/games-action/xblast/files/digest-xblast-2.9.22
new file mode 100644
index 000000000000..6625a2b8a36a
--- /dev/null
+++ b/games-action/xblast/files/digest-xblast-2.9.22
@@ -0,0 +1 @@
+MD5 658e91e053e9d7ff78979688325c806a xblast-2.9.22.tar.gz 4969378
diff --git a/games-action/xblast/metadata.xml b/games-action/xblast/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/xblast/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/xblast/xblast-2.9.22.ebuild b/games-action/xblast/xblast-2.9.22.ebuild
new file mode 100644
index 000000000000..67791a6ff427
--- /dev/null
+++ b/games-action/xblast/xblast-2.9.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xblast/xblast-2.9.22.ebuild,v 1.1 2004/09/22 07:55:34 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Bomberman clone w/network support for up to 6 players"
+HOMEPAGE="http://xblast.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xblast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ media-libs/libpng"
+
+src_compile() {
+ export MY_DATADIR="${GAMES_DATADIR}/${PN}"
+ egamesconf \
+ --enable-sound \
+ --with-otherdatadir="${MY_DATADIR}" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall game_datadir="${D}${MY_DATADIR}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+ find "${D}${MY_DATADIR}" \( -name "*akefile*" -o -name "*~" \) \
+ -exec rm -f \{\} \;
+ find "${D}${MY_DATADIR}" -type f -exec chmod a-x \{\} \;
+ prepgamesdirs
+}