summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-21 21:56:07 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-21 21:56:07 +0000
commit54b2ec6782b44e7f26b10c8368ff567446d49cc8 (patch)
treee479948123146f49c993955b2a22737e8372ef01
parentVersion bump (diff)
downloadhistorical-54b2ec6782b44e7f26b10c8368ff567446d49cc8.tar.gz
historical-54b2ec6782b44e7f26b10c8368ff567446d49cc8.tar.bz2
historical-54b2ec6782b44e7f26b10c8368ff567446d49cc8.zip
Initial import, bug 286017.
Package-Manager: portage-2.2_rc50/cvs/Linux i686
-rw-r--r--app-editors/gentoo-editor/ChangeLog11
-rw-r--r--app-editors/gentoo-editor/Manifest14
-rw-r--r--app-editors/gentoo-editor/files/gentoo-editor-1.sh30
-rw-r--r--app-editors/gentoo-editor/gentoo-editor-1.ebuild17
-rw-r--r--app-editors/gentoo-editor/metadata.xml6
5 files changed, 78 insertions, 0 deletions
diff --git a/app-editors/gentoo-editor/ChangeLog b/app-editors/gentoo-editor/ChangeLog
new file mode 100644
index 000000000000..ed74252143c5
--- /dev/null
+++ b/app-editors/gentoo-editor/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-editors/gentoo-editor
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gentoo-editor/ChangeLog,v 1.1 2009/11/21 21:56:06 ulm Exp $
+
+*gentoo-editor-1 (21 Nov 2009)
+
+ 21 Nov 2009; Ulrich Mueller <ulm@gentoo.org> +gentoo-editor-1.ebuild,
+ +files/gentoo-editor-1.sh, +metadata.xml:
+ Initial import, bug 286017. gentoo-editor script by Diego Pettenò, with
+ modifications by me.
+
diff --git a/app-editors/gentoo-editor/Manifest b/app-editors/gentoo-editor/Manifest
new file mode 100644
index 000000000000..e94842f1e7a4
--- /dev/null
+++ b/app-editors/gentoo-editor/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX gentoo-editor-1.sh 768 RMD160 87781518e132429871aecf9c658ec9c57169ed56 SHA1 accc9e21adb451674117cda5880ca2c92b9018fe SHA256 b75e8478aff81f18b917d28581d9e6d4dc45e6c44e63c47b291d19115efb2be6
+EBUILD gentoo-editor-1.ebuild 458 RMD160 f37d942e9dbeb02069853b7196a13fa98fcb9b15 SHA1 1c621bf7e056ce8ab42f9626e6e9f402a7e42719 SHA256 d50f51d899ccb59cf298da49a7847dfd33823e633313436c2ef26037eb399531
+MISC ChangeLog 467 RMD160 f4a35e3b4668f33389deed2ad54a6dfe0b451d76 SHA1 ff05ec583fa2f486a874810e9472f201401e32ec SHA256 d1aa56135c4389242d390e2bc7abe090f3ac810d42d20e0fda252e6c481056c9
+MISC metadata.xml 183 RMD160 de889cdf3481996341cd4cee764cf5c72704cf10 SHA1 1f469d9815709d2c9875a251b48fb3f688cb6f19 SHA256 7d020057c52803e7181c769edb0883bb918daa3a6c4d7f5097ff49f808d14089
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.10 (GNU/Linux)
+
+iEYEARECAAYFAksIYpEACgkQOeoy/oIi7uyQNwCgt66Y0JflEp95WAMBfnZnDDv3
+cYQAoLjOtWFZEkyRhdOKT8PBIUC+tzEB
+=RF7b
+-----END PGP SIGNATURE-----
diff --git a/app-editors/gentoo-editor/files/gentoo-editor-1.sh b/app-editors/gentoo-editor/files/gentoo-editor-1.sh
new file mode 100644
index 000000000000..0a89f483eb58
--- /dev/null
+++ b/app-editors/gentoo-editor/files/gentoo-editor-1.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+# Copyright 2009 Gentoo Foundation
+# Distributed under the terms of the MIT license
+
+# Editor wrapper script, executes ${EDITOR} on file $1.
+# We disallow options and multiple file name arguments on purpose, so
+# that packages' configure scripts cannot sniff out the type of editor.
+
+if [ $# -ne 1 ]; then
+ echo "$0: Exactly one argument required" >&2
+ exit 1
+fi
+
+file=$1
+if [ "${file#-}" != "${file}" ]; then
+ # Argument is supposed to be a file name, not an option
+ file=./${file}
+fi
+
+if [ -z "${EDITOR}" ]; then
+ # Try to get EDITOR from system profile
+ EDITOR=$(source /etc/profile &>/dev/null; echo "${EDITOR}")
+fi
+
+if [ -z "${EDITOR}" ]; then
+ echo "$0: The EDITOR variable must be set" >&2
+ exit 1
+fi
+
+exec ${EDITOR} "${file}"
diff --git a/app-editors/gentoo-editor/gentoo-editor-1.ebuild b/app-editors/gentoo-editor/gentoo-editor-1.ebuild
new file mode 100644
index 000000000000..5f731113ccfc
--- /dev/null
+++ b/app-editors/gentoo-editor/gentoo-editor-1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gentoo-editor/gentoo-editor-1.ebuild,v 1.1 2009/11/21 21:56:06 ulm Exp $
+
+DESCRIPTION="Auxiliary editor script"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ exeinto /usr/libexec
+ newexe "${FILESDIR}/${P}.sh" gentoo-editor || die
+}
diff --git a/app-editors/gentoo-editor/metadata.xml b/app-editors/gentoo-editor/metadata.xml
new file mode 100644
index 000000000000..83d335031da4
--- /dev/null
+++ b/app-editors/gentoo-editor/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<herd>emacs</herd>
+</pkgmetadata>