summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-08-10 14:44:50 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-08-10 14:44:50 +0000
commit57e067de257af797f51474b366c86ecdf98fdddd (patch)
tree4e2cf534a910dbd0428d77242e3ee7357a4fd069
parentVersion bump and fixed /etc/init.d/pptpd (diff)
downloadhistorical-57e067de257af797f51474b366c86ecdf98fdddd.tar.gz
historical-57e067de257af797f51474b366c86ecdf98fdddd.tar.bz2
historical-57e067de257af797f51474b366c86ecdf98fdddd.zip
Version bump and fixed /etc/init.d/pptpd
-rw-r--r--net-dialup/pptpd/Manifest5
-rw-r--r--net-dialup/pptpd/files/digest-pptpd-1.1.4_beta41
-rw-r--r--net-dialup/pptpd/files/pptpd-init2
-rw-r--r--net-dialup/pptpd/metadata.xml10
-rw-r--r--net-dialup/pptpd/pptpd-1.1.4_beta4.ebuild45
5 files changed, 60 insertions, 3 deletions
diff --git a/net-dialup/pptpd/Manifest b/net-dialup/pptpd/Manifest
index 6c83280137dd..265698716608 100644
--- a/net-dialup/pptpd/Manifest
+++ b/net-dialup/pptpd/Manifest
@@ -1,9 +1,10 @@
MD5 31ef21f8b112cc4eb883dc3b7bd15e36 pptpd-1.1.3.20030409.ebuild 866
MD5 52b4f6d9ab277dde649971036ba96b28 pptpd-1.1.2.ebuild 887
MD5 f03f3c4b2fd6eb67fbe08e9363c3b5dd pptpd-1.1.4_beta3.ebuild 967
+MD5 9ab2ee42bf5bf7cf16cfa9a1bfc00d51 metadata.xml 299
MD5 922d7cd56209dc13c0230c09c3e9374d pptpd-1.1.3.ebuild 894
-MD5 f4f12b03d34b8579e01edace87b296e4 ChangeLog 847
-MD5 d0567cc9d11d0dbe7cda99b677d3de0b pptpd-1.1.4_beta4.ebuild 1022
+MD5 55c467878e17891b66f78d6247eef189 ChangeLog 1097
+MD5 a999cbe0d94d973f822b6ab8b2819f57 pptpd-1.1.4_beta4.ebuild 1022
MD5 584922c862a24633123bc9af4ba32bd3 files/digest-pptpd-1.1.4_beta4 66
MD5 ccaa45fc34133bf6e2fcdae2ae6aaf6d files/digest-pptpd-1.1.3 63
MD5 045368d0e9da1b9290ee7405b94c8c55 files/digest-pptpd-1.1.4_beta3 66
diff --git a/net-dialup/pptpd/files/digest-pptpd-1.1.4_beta4 b/net-dialup/pptpd/files/digest-pptpd-1.1.4_beta4
new file mode 100644
index 000000000000..430877937192
--- /dev/null
+++ b/net-dialup/pptpd/files/digest-pptpd-1.1.4_beta4
@@ -0,0 +1 @@
+MD5 58603224998f22542e8d7ecb357bc006 pptpd-1.1.4-b4.tar.gz 157684
diff --git a/net-dialup/pptpd/files/pptpd-init b/net-dialup/pptpd/files/pptpd-init
index 09f69fb101d4..117e324ac62f 100644
--- a/net-dialup/pptpd/files/pptpd-init
+++ b/net-dialup/pptpd/files/pptpd-init
@@ -1,7 +1,7 @@
#!/sbin/runscript
depend() {
- net
+ need net
}
start() {
diff --git a/net-dialup/pptpd/metadata.xml b/net-dialup/pptpd/metadata.xml
new file mode 100644
index 000000000000..80714ac76e6f
--- /dev/null
+++ b/net-dialup/pptpd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jhhudso@gentoo.org</email>
+ <name>Jared Hudson</name>
+ <description>Interim maintainer</description>
+</maintainer>
+</pkgmetadata>
diff --git a/net-dialup/pptpd/pptpd-1.1.4_beta4.ebuild b/net-dialup/pptpd/pptpd-1.1.4_beta4.ebuild
new file mode 100644
index 000000000000..262513381cab
--- /dev/null
+++ b/net-dialup/pptpd/pptpd-1.1.4_beta4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpd/pptpd-1.1.4_beta4.ebuild,v 1.1 2003/08/10 14:44:44 jhhudso Exp $
+
+S=${WORKDIR}/poptop-1.1.4
+DESCRIPTION="Linux Point-to-Point Tunnelling Protocol Server"
+SRC_URI="mirror://sourceforge/poptop/pptpd-1.1.4-b4.tar.gz"
+HOMEPAGE="http://www.poptop.org/"
+
+DEPEND="virtual/glibc
+ net-dialup/ppp
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="$DEPEND"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="tcpd"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+ econf --with-bcrelay \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ insinto /etc
+ doins samples/pptpd.conf
+
+ insinto /etc/ppp
+ doins samples/options.pptpd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pptpd-init pptpd
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pptpd-confd pptpd
+
+ dodoc README* AUTHORS COPYING INSTALL TODO ChangeLog
+ docinto samples
+ dodoc samples/*
+}