summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-08-17 19:59:47 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-08-17 19:59:47 +0000
commit586df609b24f42f4b9ad4e71a684f1c0d97a26a6 (patch)
tree87637e0c9bc4af500048df8002019a90e34a203d
parentUnmasking hylafax-4.1.3 (diff)
downloadhistorical-586df609b24f42f4b9ad4e71a684f1c0d97a26a6.tar.gz
historical-586df609b24f42f4b9ad4e71a684f1c0d97a26a6.tar.bz2
historical-586df609b24f42f4b9ad4e71a684f1c0d97a26a6.zip
only moved
-rw-r--r--dev-libs/vdk/ChangeLog11
-rw-r--r--dev-libs/vdk/files/digest-vdk-2.0.21
-rw-r--r--dev-libs/vdk/vdk-2.0.2.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/vdk/ChangeLog b/dev-libs/vdk/ChangeLog
new file mode 100644
index 000000000000..c1fc4f9b64fa
--- /dev/null
+++ b/dev-libs/vdk/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-libs/vdk
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/ChangeLog,v 1.1 2002/08/17 19:59:47 bass Exp $
+
+*vdk-2.0.2 (12 Aug 2002)
+
+ 12 Aug 2002; Joe Tennies <rotund@fatnsoft.com> vdk-2.0.2.ebuild:
+ First release... based on bass@gentoo.org's original vdkbuilder
+ script that built the vdk library.
+
+
diff --git a/dev-libs/vdk/files/digest-vdk-2.0.2 b/dev-libs/vdk/files/digest-vdk-2.0.2
new file mode 100644
index 000000000000..66f80f8d5c24
--- /dev/null
+++ b/dev-libs/vdk/files/digest-vdk-2.0.2
@@ -0,0 +1 @@
+MD5 ed312dbb897056c39a299c944710f4df vdk-2.0.2.tar.gz 920055
diff --git a/dev-libs/vdk/vdk-2.0.2.ebuild b/dev-libs/vdk/vdk-2.0.2.ebuild
new file mode 100644
index 000000000000..4322ecb2e593
--- /dev/null
+++ b/dev-libs/vdk/vdk-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/vdk-2.0.2.ebuild,v 1.1 2002/08/17 19:59:47 bass Exp $
+
+DESCRIPTION="The Visual Development Kit used for VDK Builder."
+SRC_URI="mirror://sourceforge/vdkbuilder/${P}.tar.gz"
+HOMEPAGE="http://vdkbuilder.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="dev-libs/atk
+ x11-libs/pango
+ dev-libs/glib
+ dev-util/pkgconfig
+ >=x11-libs/gtk+-2.0.3
+ gnome? ( gnome-base/libgnome )"
+# app-doc/doxygen"
+
+src_compile() {
+
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome=yes" \
+ || myconf="${myconf} --enable-gnome=no"
+
+ econf ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README TODO
+}