summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-17 08:37:29 +0000
commit5d9691780e614b3d68e037d913c51a32913f7144 (patch)
treeef4667bbf9dffb0f30b4322045e24fdf4fd51d2d
parentfix-up :) (diff)
downloadhistorical-5d9691780e614b3d68e037d913c51a32913f7144.tar.gz
historical-5d9691780e614b3d68e037d913c51a32913f7144.tar.bz2
historical-5d9691780e614b3d68e037d913c51a32913f7144.zip
lots of new xfs stuff
-rw-r--r--sys-apps/attr/attr-1.1.3.ebuild32
-rw-r--r--sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild6
2 files changed, 35 insertions, 3 deletions
diff --git a/sys-apps/attr/attr-1.1.3.ebuild b/sys-apps/attr/attr-1.1.3.ebuild
new file mode 100644
index 000000000000..3f035448b925
--- /dev/null
+++ b/sys-apps/attr/attr-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-1.1.3.ebuild,v 1.1 2001/11/17 08:37:29 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild b/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild
index 9b5b6648db24..eed1f00143a5 100644
--- a/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild
+++ b/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild,v 1.2 2001/11/17 08:01:21 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild,v 1.3 2001/11/17 08:37:29 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="xfs filesystem utilities"
@@ -23,8 +23,8 @@ src_compile() {
# 3) we remove a hard-coded "-O1"
# 4) we fix some Makefile-created library symlinks that contains absolute paths
cp include/builddefs include/builddefs.orig
- sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/xfsprogs:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
- make || die
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ emake || die
}
src_install() {