summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:39:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:39:27 +0000
commit5ee8321fdf64b936271655d38e6a1d908df3a4d4 (patch)
treeff3198a329730248038565822c9e9c5e4cfbb48b
parentBump to 0.7.159, development version (diff)
downloadhistorical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.tar.gz
historical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.tar.bz2
historical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.zip
Initial import to the main tree
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
-rw-r--r--dev-python/lp_solve/ChangeLog10
-rw-r--r--dev-python/lp_solve/Manifest5
-rw-r--r--dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch50
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0.ebuild46
-rw-r--r--dev-python/lp_solve/metadata.xml8
-rw-r--r--dev-python/oosuite/ChangeLog10
-rw-r--r--dev-python/oosuite/Manifest5
-rw-r--r--dev-python/oosuite/files/oosuite-0.37-no-init-msg.patch72
-rw-r--r--dev-python/oosuite/metadata.xml23
-rw-r--r--dev-python/oosuite/oosuite-0.37.ebuild96
10 files changed, 325 insertions, 0 deletions
diff --git a/dev-python/lp_solve/ChangeLog b/dev-python/lp_solve/ChangeLog
new file mode 100644
index 000000000000..8e0326f83217
--- /dev/null
+++ b/dev-python/lp_solve/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/lp_solve
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/ChangeLog,v 1.1 2012/01/07 20:36:32 bicatali Exp $
+
+*lp_solve-5.5.2.0 (07 Jan 2012)
+
+ 07 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +lp_solve-5.5.2.0.ebuild, +files/lp_solve-5.5.2.0-setup.patch, +metadata.xml:
+ Initial import to the main tree
+
diff --git a/dev-python/lp_solve/Manifest b/dev-python/lp_solve/Manifest
new file mode 100644
index 000000000000..1b19c1de1793
--- /dev/null
+++ b/dev-python/lp_solve/Manifest
@@ -0,0 +1,5 @@
+AUX lp_solve-5.5.2.0-setup.patch 1637 RMD160 7b84663c24feee88d5a798dd16da557850076431 SHA1 e86f72793bd896e5651da3de80df91ac49614053 SHA256 d2e0e070a2e0adc2703870f677c9177a6db8f7c3d749e43d47526377480b9a44
+DIST lp_solve_5.5.2.0_Python_source.tar.gz 58017 RMD160 c3d5b387ed85a222b17f33f1987d25da80182afd SHA1 058cced6b6a27cc160c9c5054c6b94b0eae6d989 SHA256 79683bc262e9da5b2fa7338ba190a9cd10559b9f2dbcb8f3bf07e2a81083ac51
+EBUILD lp_solve-5.5.2.0.ebuild 940 RMD160 1d5f9f56499bfa7f986c8c703c10c286b91a47af SHA1 a9050dd4c74501493651dce8014695e951dbaacf SHA256 065db88cc0c0c36fbcf0ff57339f5009168ad38bb0a820fd5dca16cc583045a1
+MISC ChangeLog 323 RMD160 79e0cfc1e373f5bb444c8ba502329fd50caba9f7 SHA1 47607cf807dcbc790c3052026da6f1c1df3a2771 SHA256 a2389dc7747e43e06870a82a79a3f5d8ee1b907277563efc060e173b1605e38e
+MISC metadata.xml 284 RMD160 dd92877d4154d75095e0deb691e80a524cfaba44 SHA1 c96d31d1e40aba23462d587eb4570ed25693f949 SHA256 855182f93d92424de2d13c07d48f0f7f369c84c86b1bc36142764d2761d9f45a
diff --git a/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
new file mode 100644
index 000000000000..a28b8179d261
--- /dev/null
+++ b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
@@ -0,0 +1,50 @@
+--- setup.py.orig 2012-01-07 20:27:45.072840503 +0000
++++ setup.py 2012-01-07 20:24:22.127570128 +0000
+@@ -1,26 +1,25 @@
+ from distutils.core import setup, Extension
+ from os import getenv
+ import sys
+-import os
+-p = sys.prefix
+-NUMPYPATH = '.'
+-if os.path.isdir(p + '/include/numpy'):
+- NUMPY = 'NUMPY'
+-elif os.path.isdir(p + '/Lib/site-packages/numpy/core/include/numpy'):
+- NUMPY = 'NUMPY'
+- NUMPYPATH = p + '/Lib/site-packages/numpy/core/include'
+-else:
++import os, os.path
++
++try:
++ import numpy
++ NUMPY = 'NUMPY'
++ NUMPYPATH = numpy.get_include()
++except:
+ NUMPY = 'NONUMPY'
+-print 'numpy: ' + NUMPY
++ NUMPYPATH = '.'
++
+ windir = getenv('windir')
+ if windir == None:
+ WIN32 = 'NOWIN32'
+- LPSOLVE55 = '../../lpsolve55/bin/ux32'
++ LPSOLVEINC = os.path.join(sys.prefix,'include','lpsolve')
+ else:
+ WIN32 = 'WIN32'
+ LPSOLVE55 = '../../lpsolve55/bin/win32'
+ setup (name = "lpsolve55",
+- version = "5.5.0.9",
++ version = "5.5.2.0",
+ description = "Linear Program Solver, Interface to lpsolve",
+ author = "Peter Notebaert",
+ author_email = "lpsolve@peno.be",
+@@ -29,8 +28,7 @@
+ ext_modules = [Extension("lpsolve55",
+ ["lpsolve.c", "hash.c", "pythonmod.c"],
+ define_macros=[('PYTHON', '1'), (WIN32, '1'), ('NODEBUG', '1'), ('DINLINE', 'static'), (NUMPY, '1'), ('_CRT_SECURE_NO_WARNINGS', '1')],
+- include_dirs=['../..', NUMPYPATH],
+- library_dirs=[LPSOLVE55],
++ include_dirs=[LPSOLVEINC, NUMPYPATH],
+ libraries = ["lpsolve55"])
+ ]
+ )
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
new file mode 100644
index 000000000000..895aad7aac03
--- /dev/null
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild,v 1.1 2012/01/07 20:36:32 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.4 3*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrappers for lpsolve"
+HOMEPAGE="http://lpsolve.sourceforge.net/5.5/Python.htm"
+SRC_URI="mirror://sourceforge/lpsolve/${PN}_${PV}_Python_source.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/numpy
+ sci-mathematics/lpsolve"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${PN}_5.5/extra/Python/"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-setup.patch
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
+ "$(PYTHON)" lpdemo.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc changes
+ use doc && dohtml Python.htm
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins ex*py
+}
diff --git a/dev-python/lp_solve/metadata.xml b/dev-python/lp_solve/metadata.xml
new file mode 100644
index 000000000000..e8988df3202d
--- /dev/null
+++ b/dev-python/lp_solve/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ Python wrapper modules for the linear programming library lpsolve.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/oosuite/ChangeLog b/dev-python/oosuite/ChangeLog
new file mode 100644
index 000000000000..55e240c0272b
--- /dev/null
+++ b/dev-python/oosuite/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/oosuite
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/ChangeLog,v 1.1 2012/01/07 20:39:27 bicatali Exp $
+
+*oosuite-0.37 (07 Jan 2012)
+
+ 07 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +oosuite-0.37.ebuild,
+ +files/oosuite-0.37-no-init-msg.patch, +metadata.xml:
+ Initial import to the main tree
+
diff --git a/dev-python/oosuite/Manifest b/dev-python/oosuite/Manifest
new file mode 100644
index 000000000000..3ab5ee99ede2
--- /dev/null
+++ b/dev-python/oosuite/Manifest
@@ -0,0 +1,5 @@
+AUX oosuite-0.37-no-init-msg.patch 1884 RMD160 92b609b8da183997edb341ee21d9c941f122d769 SHA1 4f0a54dc214adf0340acf77a15a5e616bbaac31c SHA256 996b2e29d66babe03b53e84560ee623b562c7849e2ce6f782eed26d1a4a0ebe8
+DIST OOSuite-0.37.zip 472085 RMD160 fc3b89cd6b79d5ad43b0e79ed6bdf8e864c4347f SHA1 2661d187921ae80c678ba14ffcf1560f482566fc SHA256 8a98e6039202c1d25f2282053ad6e00a65750804fc8b567cad1e91177d771d85
+EBUILD oosuite-0.37.ebuild 2093 RMD160 b69b65ba60a8eeb7ed3736de88950c96abf6bcb7 SHA1 ab343549fb3a433916fdced5a97e67806c69ad80 SHA256 d0c9c29887543c282ace10585a9962cc304a29b01c3aea668a443c1cd7fd4331
+MISC ChangeLog 316 RMD160 eed87a3d83c3dfc1b4275f8211d81b3f79fd3614 SHA1 03b99bf0296e62931b1a87dafb50ab58cac570d8 SHA256 34b1fbaec747e41d109ed67aea3d138ff0d32776a3b878f7ed7b8245cbbb6485
+MISC metadata.xml 1170 RMD160 0dd5eb20b1d59bdfcfeb3f906accd5f087a5813e SHA1 b0d4fcdc38b628355bac0deee0c8c54618e34481 SHA256 c1dc724ec82b665527c6857d834e378dd4f0435a75aee702d97bba45a3e61f11
diff --git a/dev-python/oosuite/files/oosuite-0.37-no-init-msg.patch b/dev-python/oosuite/files/oosuite-0.37-no-init-msg.patch
new file mode 100644
index 000000000000..db477e55a87f
--- /dev/null
+++ b/dev-python/oosuite/files/oosuite-0.37-no-init-msg.patch
@@ -0,0 +1,72 @@
+diff -Nur PythonPackages.orig/FuncDesigner/FuncDesigner/__init__.py PythonPackages/FuncDesigner/FuncDesigner/__init__.py
+--- PythonPackages.orig/FuncDesigner/FuncDesigner/__init__.py 2011-12-15 15:43:56.000000000 +0000
++++ PythonPackages/FuncDesigner/FuncDesigner/__init__.py 2012-01-07 16:26:48.000000000 +0000
+@@ -15,31 +15,3 @@
+ from interpolate import scipy_UnivariateSpline as interpolator
+ from integrate import integrator
+ __version__ = '0.37'
+-
+-isE = False
+-try:
+- import enthought
+- isE = True
+-except ImportError:
+- pass
+-try:
+- import envisage
+- import mayavi
+- isE = True
+-except ImportError:
+- pass
+-try:
+- import xy
+- isE = False
+-except ImportError:
+- pass
+-
+-if isE:
+- s = """
+- Seems like you are using OpenOpt from
+- commercial Enthought Python Distribution;
+- consider using free GPL-licensed alternatives
+- PythonXY (http://www.pythonxy.com) or
+- Sage (http://sagemath.org) instead.
+- """
+- print(s)
+diff -Nur PythonPackages.orig/OpenOpt/openopt/__init__.py PythonPackages/OpenOpt/openopt/__init__.py
+--- PythonPackages.orig/OpenOpt/openopt/__init__.py 2011-10-23 19:17:28.000000000 +0100
++++ PythonPackages/OpenOpt/openopt/__init__.py 2012-01-07 16:26:19.000000000 +0000
+@@ -19,33 +19,6 @@
+ from mfa import MFA
+
+
+-isE = False
+-try:
+- import enthought
+- isE = True
+-except ImportError:
+- pass
+-try:
+- import envisage
+- import mayavi
+- isE = True
+-except ImportError:
+- pass
+-try:
+- import xy
+- isE = False
+-except ImportError:
+- pass
+-
+-if isE:
+- s = """
+- Seems like you are using OpenOpt from
+- commercial Enthought Python Distribution;
+- consider using free GPL-licensed alternatives
+- PythonXY (http://www.pythonxy.com) or
+- Sage (http://sagemath.org) instead.
+- """
+- print(s)
+
+
+ #__all__ = filter(lambda s:not s.startswith('_'),dir())
diff --git a/dev-python/oosuite/metadata.xml b/dev-python/oosuite/metadata.xml
new file mode 100644
index 000000000000..291eba128960
--- /dev/null
+++ b/dev-python/oosuite/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ The OpenOpt suite of Python packages contains the following modules:
+ * OpenOpt: universal numerical optimization package with
+ several solvers (e.g. ralg) and connections to tens of other,
+ graphical output of convergence.
+ * FuncDesigner: tool to rapidly build functions over
+ variables/arrays and get their dense/sparse derivatives via
+ automatic differentiation, integration (with specifiable accuracy by
+ interalg), interpolation, uncertainty analysis and interval
+ analysis, eigenvalue analysis, solve systems of linear/nonlinear/ODE
+ equations and numerical optimization problems coded in FuncDesigner
+ by OpenOpt.
+ * DerApproximator: tool to get (or check user-supplied) derivatives
+ via finite-difference approximation
+ * SpaceFuncs: tool for 2D, 3D, N-dimensional geometric modeling with
+ possibilities of parametrized calculations, numerical optimization
+ and solving systems of geometrical equations.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/oosuite/oosuite-0.37.ebuild b/dev-python/oosuite/oosuite-0.37.ebuild
new file mode 100644
index 000000000000..df1c2abf6ecb
--- /dev/null
+++ b/dev-python/oosuite/oosuite-0.37.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/oosuite-0.37.ebuild,v 1.1 2012/01/07 20:39:27 bicatali Exp $
+
+EAPI=4
+
+# python eclass cruft
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="tk?"
+RESTRICT_PYTHON_ABIS="2.4"
+
+inherit distutils eutils
+
+MYPN="OOSuite"
+MYPID="f/f3"
+
+DESCRIPTION="OpenOpt suite of Python modules for numerical optimization"
+HOMEPAGE="http://openopt.org/"
+SRC_URI="http://openopt.org/images/${MYPID}/${MYPN}.zip -> ${MYPN}-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples minimal tk"
+
+RDEPEND="dev-python/numpy
+ !minimal? (
+ dev-python/cvxopt[glpk]
+ dev-python/lp_solve
+ dev-python/matplotlib
+ dev-python/setproctitle
+ sci-libs/nlopt[python]
+ sci-libs/scipy )"
+DEPEND="app-arch/unzip
+ dev-python/numpy
+ dev-python/setuptools"
+
+S="${WORKDIR}/PythonPackages"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-init-msg.patch
+ OO_DIRS="DerApproximator FuncDesigner OpenOpt SpaceFuncs"
+ find . -name "*COPYING*" -delete
+ # move all examples and tests away to ease installation in proper directory
+ mkdir "${WORKDIR}/examples"
+ local d e
+ for d in ${OO_DIRS}; do
+ mkdir "${WORKDIR}/examples/${d}"
+ for e in $(find ${d} -type d -name examples -or -name tests -or -name doc); do
+ mv ${e} "${WORKDIR}/examples/${d}/" || die
+ done
+ done
+}
+
+src_compile() {
+ local d
+ for d in ${OO_DIRS}; do
+ pushd ${d} > /dev/null
+ distutils_src_compile
+ popd > /dev/null
+ done
+}
+
+src_test() {
+ testing() {
+ local d t oldpath=${PYTHONPATH}
+ for d in ${OO_DIRS}; do
+ PYTHONPATH="${S}/${d}/build-${PYTHON_ABI}/lib:${PYTHONPATH}"
+ done
+ export PYTHONPATH
+ cd "${WORKDIR}"/examples
+ for t in \
+ DerApproximator/tests/t_check.py \
+ FuncDesigner/examples/sle1.py \
+ OpenOpt/examples/nlp_1.py \
+ SpaceFuncs/examples/triangle.py
+ do
+ "$(PYTHON)" ${t}
+ done
+ export PYTHONPATH=${oldpath}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ local d
+ for d in ${OO_DIRS}; do
+ pushd ${d} > /dev/null
+ distutils_src_install
+ popd > /dev/null
+ done
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/examples
+ fi
+}