summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-03-27 22:17:24 +0000
committerDonny Davies <woodchip@gentoo.org>2002-03-27 22:17:24 +0000
commit84c898db4a96e5e1262c21609e2112f3a6c99465 (patch)
treecb979de8335181df16cd6268340abd88a2d9c76e
parentman page/LFH fixes (diff)
downloadhistorical-84c898db4a96e5e1262c21609e2112f3a6c99465.tar.gz
historical-84c898db4a96e5e1262c21609e2112f3a6c99465.tar.bz2
historical-84c898db4a96e5e1262c21609e2112f3a6c99465.zip
update to lastest apache+mod_ssl
-rw-r--r--net-www/apache/ChangeLog16
-rw-r--r--net-www/apache/apache-1.3.23-r1.ebuild102
-rw-r--r--net-www/apache/apache-1.3.24.ebuild (renamed from net-www/apache/apache-1.3.23.ebuild)10
-rw-r--r--net-www/apache/files/digest-apache-1.3.232
-rw-r--r--net-www/apache/files/digest-apache-1.3.23-r12
-rw-r--r--net-www/apache/files/digest-apache-1.3.242
6 files changed, 16 insertions, 118 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 5fb91287d667..531b038aae14 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,15 +1,19 @@
# ChangeLog for net-www/apache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.2 2002/02/04 20:20:06 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.3 2002/03/27 22:17:24 woodchip Exp $
+
+*apache-1.3.24 (27 Mar 2002)
+
+ 27 Mar 2002; Donny Davies <woodchip@gentoo.org> apache-1.3.24.ebuild :
+
+ Bump up to apache-1.3.24, mod_ssl-2.8.8; fixes some security issues. This port is
+ being re-written, will be ready soon.
*apache-1.3.23 (4 Feb 2002)
- 4 Feb 2002; Donny Davies <woodchip@gentoo.org> :
+ 4 Feb 2002; Donny Davies <woodchip@gentoo.org> apache-1.3.23.ebuild :
- Bump apache to 1.3.23, mod_ssl to 2.8.6-1.3.23. Im working on some big changes
- to this port, namely configurable HTTPD_ROOT, s/httpd/apache/, integration of
- many more mods, performance tuning and more. Taking ideas from the apache
- toolbox. Stay tuned to this station for more updates, dont turn that dial ;)
+ Bump apache to 1.3.23, mod_ssl to 2.8.6-1.3.23.
*apache-1.3.22-r6 (1 Feb 2002)
diff --git a/net-www/apache/apache-1.3.23-r1.ebuild b/net-www/apache/apache-1.3.23-r1.ebuild
deleted file mode 100644
index 3d7644da4ce6..000000000000
--- a/net-www/apache/apache-1.3.23-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.23-r1.ebuild,v 1.1 2002/03/04 19:31:46 m0rpheus Exp $
-
-AV="1.3.23"
-MSV="2.8.7"
-
-A="apache_${AV}.tar.gz mod_ssl-${MSV}-${AV}.tar.gz"
-S=${WORKDIR}/apache_${AV}
-DESCRIPTION="The Apache Web Server"
-HOMEPAGE="http://www.apache.org http://www.modssl.org"
-SRC_URI="http://httpd.apache.org/dist/httpd/apache_${AV}.tar.gz
- ftp://ftp.modssl.org/source/mod_ssl-${MSV}-${AV}.tar.gz"
-
-DEPEND="virtual/glibc
- >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-src_compile() {
-
- local myconf
- export SSL_BASE=SYSTEM
- export CFLAGS="${CFLAGS} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
- export RULE_EXPAT=NO
-
- if [ "`use ssl`" ]; then
- myconf="${myconf} --enable-module=ssl"
- cd ${S}/../mod_ssl-${MSV}-${AV}
- ./configure --with-apache=${S} --with-ssl=SYSTEM || die
- cd ${S}
- fi
-
- ./configure --prefix=/usr/local/httpd --bindir=/usr/bin \
- --sbindir=/usr/sbin --datadir=/usr/local/httpd \
- --sysconfdir=/etc/httpd --libexecdir=/usr/lib/apache \
- --mandir=/usr/share/man --logfiledir=/var/log/apache --localstatedir=/var/lock \
- --proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
- --enable-module=all \
- --enable-shared=max --suexec-caller=wwwrun \
- --suexec-userdir=public_html --suexec-uidmin=96 \
- --suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin" \
- --disable-rule=EXPAT --with-perl=/usr/bin/perl ${myconf}
- assert "bad configure"
-
- make || die "compile problem"
- use ssl && ( make certificate TYPE=dummy || die "make ssl certificate failed" )
-}
-
-src_install() {
-
- make install-quiet root=${D} || die
- dodoc ABOUT_APACHE Announcement INSTALL* KEYS LICENSE* README* WARNING* ${FILESDIR}/httpd.conf
- dosed "s:^PIDFILE.*:PIDFILE=/var/run/httpd.pid:" /usr/sbin/apachectl
- dosed "s:/usr/local/bin/perl5:/usr/bin/perl:" \
- /usr/local/httpd/htdocs/manual/search/manual-index.cgi
-
- if [ "`use ssl`" ] ; then
- cd ../mod_ssl-${MSV}-${AV}
- docinto mod_ssl
- dodoc ANNOUNCE CHANGES CREDITS INSTALL* LICENSE NEWS README*
- fi
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/httpd.rc6 httpd
- insinto /etc/conf.d
- newins ${FILESDIR}/httpd.confd httpd
- insinto /etc/httpd
- doins ${FILESDIR}/httpd.conf
-}
-
-pkg_config() {
-
- #${ROOT}/sbin/rc-update add httpd default
-
- if [ "$ServerName" = "" ] ; then
- ServerName=`uname -n`
- fi
- if [ "$ServerAdmin" = "" ] ; then
- ServerAdmin="webmaster\@$ServerName"
- fi
-
- mv ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
- sed -e "s/^\#ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerName.*/ServerName $ServerName/" \
- -e "s/^ServerAdmin.*/ServerAdmin $ServerAdmin/" \
- ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
-}
-
-pkg_prerm() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
- /etc/init.d/httpd stop
- fi
-}
-
-pkg_preinst() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/httpd ] ; then
- /etc/init.d/httpd stop
- fi
-}
diff --git a/net-www/apache/apache-1.3.23.ebuild b/net-www/apache/apache-1.3.24.ebuild
index b28869dd4599..5dd26dfb39a2 100644
--- a/net-www/apache/apache-1.3.23.ebuild
+++ b/net-www/apache/apache-1.3.24.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.23.ebuild,v 1.1 2002/02/04 20:20:06 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.24.ebuild,v 1.1 2002/03/27 22:17:24 woodchip Exp $
-AV="1.3.23"
-MSV="2.8.6"
+AV=${PV}
+MSV="2.8.8"
-A="apache_${AV}.tar.gz mod_ssl-${MSV}-${AV}.tar.gz"
S=${WORKDIR}/apache_${AV}
DESCRIPTION="The Apache Web Server"
HOMEPAGE="http://www.apache.org http://www.modssl.org"
@@ -38,7 +36,7 @@ src_compile() {
--proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
--enable-module=all \
--enable-shared=max --suexec-caller=wwwrun \
- --suexec-userdir=public_html --suexec-uidmin=96 \
+ --enable-suexec --suexec-userdir=public_html --suexec-uidmin=96 \
--suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin" \
--disable-rule=EXPAT --with-perl=/usr/bin/perl ${myconf}
assert "bad configure"
diff --git a/net-www/apache/files/digest-apache-1.3.23 b/net-www/apache/files/digest-apache-1.3.23
deleted file mode 100644
index ed342e8f3fdd..000000000000
--- a/net-www/apache/files/digest-apache-1.3.23
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 4499443fa1d604243467afe64522abac apache_1.3.23.tar.gz 2210130
-MD5 f3c65f873eaf391721d1c474e6485c22 mod_ssl-2.8.6-1.3.23.tar.gz 752025
diff --git a/net-www/apache/files/digest-apache-1.3.23-r1 b/net-www/apache/files/digest-apache-1.3.23-r1
deleted file mode 100644
index 1d45274a0480..000000000000
--- a/net-www/apache/files/digest-apache-1.3.23-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 4499443fa1d604243467afe64522abac apache_1.3.23.tar.gz 2210130
-MD5 3e3a6a630cf56daa44f33d6da8bc5e65 mod_ssl-2.8.7-1.3.23.tar.gz 751993
diff --git a/net-www/apache/files/digest-apache-1.3.24 b/net-www/apache/files/digest-apache-1.3.24
new file mode 100644
index 000000000000..770251a0ba76
--- /dev/null
+++ b/net-www/apache/files/digest-apache-1.3.24
@@ -0,0 +1,2 @@
+MD5 ebea6588c3954731fcc318d29bc82409 apache_1.3.24.tar.gz 2232504
+MD5 a48e8b5878f221694983747e60973662 mod_ssl-2.8.8-1.3.24.tar.gz 752322