summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-01 11:16:49 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-01 11:16:49 +0000
commit8cb7a05fdb8d24a9a4aeb0dc4d2f7e479c414fa5 (patch)
treed6b33e6adf149d1f81aa01bd19a6318d41765695
parentconverted SLOTs to a whole number (diff)
downloadhistorical-8cb7a05fdb8d24a9a4aeb0dc4d2f7e479c414fa5.tar.gz
historical-8cb7a05fdb8d24a9a4aeb0dc4d2f7e479c414fa5.tar.bz2
historical-8cb7a05fdb8d24a9a4aeb0dc4d2f7e479c414fa5.zip
bugfix
-rw-r--r--net-mail/nmh/ChangeLog9
-rw-r--r--net-mail/nmh/files/digest-nmh-1.0.4-r21
-rw-r--r--net-mail/nmh/nmh-1.0.4-r2.ebuild60
3 files changed, 69 insertions, 1 deletions
diff --git a/net-mail/nmh/ChangeLog b/net-mail/nmh/ChangeLog
index 4a1f46a9b15c..7b1c03582c8a 100644
--- a/net-mail/nmh/ChangeLog
+++ b/net-mail/nmh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/nmh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/nmh/ChangeLog,v 1.2 2002/05/04 03:15:25 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/nmh/ChangeLog,v 1.3 2002/06/01 11:16:49 azarah Exp $
+
+*nmh-1.0.4-r2 (1 June 2002)
+
+ 1 June 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Resolve bug #2338. Seems without a valid /usr/bin/vi, this sandbox
+ violation accured. Should be fixed in some better way.
*nmh-1.0.4-r1 (3 May 2002)
diff --git a/net-mail/nmh/files/digest-nmh-1.0.4-r2 b/net-mail/nmh/files/digest-nmh-1.0.4-r2
new file mode 100644
index 000000000000..96f0c1cac86b
--- /dev/null
+++ b/net-mail/nmh/files/digest-nmh-1.0.4-r2
@@ -0,0 +1 @@
+MD5 fd0dc5c84f67cfbcdfdc1196a5298e47 nmh-1.0.4.tar.gz 683215
diff --git a/net-mail/nmh/nmh-1.0.4-r2.ebuild b/net-mail/nmh/nmh-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..ca17d93b40b1
--- /dev/null
+++ b/net-mail/nmh/nmh-1.0.4-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2001-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# Author: Damon Conway <damon@3jane.net>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/nmh/nmh-1.0.4-r2.ebuild,v 1.1 2002/06/01 11:16:49 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="New MH mail reader"
+SRC_URI="ftp://ftp.mhost.com/pub/nmh/${P}.tar.gz"
+HOMEPAGE="http://www.mhost.com/nmh/"
+
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =sys-libs/db-1.85*
+ >=sys-libs/ncurses-5.2
+ app-editors/vi"
+
+# Without a valid /usr/bin/vi, the following sandbox violation is produced:
+#
+# --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
+# LOG FILE = "/tmp/sandbox-nmh-1.0.4-r2-9221.log"
+#
+# open_wr: /.nonexist-file.swp
+# open_wr: /.nonexist-file.swp
+# open_wr: /root/tmp/nonexist-file.swp
+# open_wr: /root/tmp/nonexist-file.swp
+# --------------------------------------------------------------------------------
+#
+# Thus I am making vi a DEPEND until somebody with more time can figure out a
+# better way of fixing this. NOTE: /usr/bin/vi being a symlink to /usr/bin/vim
+# also fixes this problem.
+
+
+src_compile() {
+ [ -z "${EDITOR}" ] && export EDITOR="/usr/bin/vi"
+ [ -z "${PAGER}" ] && export PAGER="/usr/bin/more"
+
+ # Redifining libdir to be bindir so the support binaries get installed
+ # correctly. Since no libraries are installed with nmh, this does not
+ # pose a problem at this time.
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-editor=${EDITOR} \
+ --with-pager=${PAGER} \
+ --enable-nmh-pop \
+ --sysconfdir=/etc/nmh \
+ --libdir=/usr/bin || die
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/bin \
+ etcdir=${D}/etc/nmh install || die
+ dodoc COMPLETION-TCSH COMPLETION-ZSH TODO FAQ DIFFERENCES \
+ MAIL.FILTERING Changelog*
+}
+