summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-09 20:16:26 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-09 20:16:26 +0000
commit8f26de204454964916139397107ec8a7b8fbbd45 (patch)
treeac297ee0cc43468e7ae63b6166eb46ae0cfd3075
parentTrim empty lines. Fix broken Manifest. (diff)
downloadhistorical-8f26de204454964916139397107ec8a7b8fbbd45.tar.gz
historical-8f26de204454964916139397107ec8a7b8fbbd45.tar.bz2
historical-8f26de204454964916139397107ec8a7b8fbbd45.zip
cleanup
Package-Manager: portage-2.0.51.22-r1
-rw-r--r--dev-java/commons-pool/ChangeLog6
-rw-r--r--dev-java/commons-pool/Manifest14
-rw-r--r--dev-java/commons-pool/commons-pool-1.1.ebuild43
-rw-r--r--dev-java/commons-pool/commons-pool-1.2.ebuild30
4 files changed, 42 insertions, 51 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index 34f9ca1397de..58d13a25b50b 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.25 2005/05/18 11:23:53 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.26 2005/07/09 20:16:26 axxo Exp $
+
+ 09 Jul 2005; Thomas Matthijs <axxo@gentoo.org> commons-pool-1.1.ebuild,
+ commons-pool-1.2.ebuild:
+ cleanup
18 May 2005; Markus Rothe <corsair@gentoo.org> commons-pool-1.2.ebuild:
Stable on ppc64
diff --git a/dev-java/commons-pool/Manifest b/dev-java/commons-pool/Manifest
index 23cfe4079f3f..2a515ae6681d 100644
--- a/dev-java/commons-pool/Manifest
+++ b/dev-java/commons-pool/Manifest
@@ -1,16 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 35d637f8e7b856ebe8cf5be49bad5e2f ChangeLog 3704
-MD5 c45f55688d3dc984b988fad993882292 commons-pool-1.1.ebuild 1435
-MD5 3bd7c12d41066a4f4b37b061599a415e commons-pool-1.2.ebuild 1425
+MD5 08a8be4d05b71f77794b1cc027c2e979 commons-pool-1.2.ebuild 1317
+MD5 71ed1c628bb58dea58ce0eb26ad19cb7 commons-pool-1.1.ebuild 1310
+MD5 da7b364e7d085322dc5483aecec0f4b2 ChangeLog 3813
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 b8d9ac4e67767842878c535474df7961 files/digest-commons-pool-1.1 71
MD5 d41c8c7c7d3b3490c197807fbe38f8a6 files/digest-commons-pool-1.2 72
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCz0NZI1lqEGTUzyQRAkULAJ9wqZxijNy1HMaTC3Q8mSwZxo01zwCfVsT7
-c8et+WklTpu2jVSXFqoUUoE=
-=WTST
+iD8DBQFC0DC6/rLF9B432nYRApdEAKC4idCZdo+ywuYb8Kir0xYaoTT+xwCeKQuM
+gB8qs5dksxhjcKXy/QYLN1c=
+=Ur0c
-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-pool/commons-pool-1.1.ebuild b/dev-java/commons-pool/commons-pool-1.1.ebuild
index 1cbc3c03bcdd..24de7d568e8d 100644
--- a/dev-java/commons-pool/commons-pool-1.1.ebuild
+++ b/dev-java/commons-pool/commons-pool-1.1.ebuild
@@ -1,52 +1,45 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.12 2005/07/09 03:23:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.13 2005/07/09 20:16:26 axxo Exp $
inherit java-pkg
DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
SRC_URI="mirror://apache/jakarta/commons/pool/source/${P}-src.tar.gz"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
- >=dev-java/commons-collections-2.0
+ ${RDEPEND}
junit? ( >=dev-java/junit-3.7 )
jikes? ( dev-java/jikes )"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/commons-collections-2.0"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
IUSE="jikes junit doc"
-src_compile() {
- local myc
+src_unpack() {
+ unpack ${A}
cd ${S}
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
-
- if use jikes ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if use junit ; then
- echo "junit.jar=`java-config --classpath=junit`" >> build.properties
- ANT_OPTS=${myc} ant || die "Testing Classes Failed"
- fi
+ echo "commons-collections.jar=$(java-pkg_getjars commons-collections)" > build.properties
+ use junit && echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
+}
- ANT_OPTS=${myc} ant dist || die "Compilation Failed"
+src_compile() {
+ local antflags="dist"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadoc"
- if use doc ; then
- ANT_OPTS=${myc} ant javadoc || die "Unable to create documents"
- fi
+ ant ${antflags} || die "Compilation Failed"
}
-src_install () {
- java-pkg_dojar dist/${PN}*.jar || die "Unable to install"
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
dodoc README.txt
dohtml STATUS.html PROPOSAL.html
- if use doc ; then
- java-pkg_dohtml -r dist/docs/*
- fi
+ use doc && java-pkg_dohtml -r dist/docs/*
}
diff --git a/dev-java/commons-pool/commons-pool-1.2.ebuild b/dev-java/commons-pool/commons-pool-1.2.ebuild
index 3bd548983afc..eff692aabd10 100644
--- a/dev-java/commons-pool/commons-pool-1.2.ebuild
+++ b/dev-java/commons-pool/commons-pool-1.2.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.2.ebuild,v 1.10 2005/07/09 03:23:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.2.ebuild,v 1.11 2005/07/09 20:16:26 axxo Exp $
inherit java-pkg
DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
SRC_URI="mirror://apache/jakarta/commons/pool/source/${P}-src.tar.gz"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
- >=dev-java/commons-collections-2.0
+ ${RDEPEND}
junit? ( >=dev-java/junit-3.7 )
jikes? ( dev-java/jikes )"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/commons-collections-2.0"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="x86 ~ppc sparc amd64 ppc64"
@@ -23,29 +23,23 @@ src_unpack() {
unpack ${A}
cd ${S}
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
- use junit && echo "junit.jar=`java-config --classpath=junit`" >> build.properties
+ echo "commons-collections.jar=$(java-pkg_getjars commons-collections)" > build.properties
+ use junit && echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
}
src_compile() {
- local antflags
-
+ local antflags="dist"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- ant ${antflags} dist || die "Compilation Failed"
-
- if use junit; then
- ant ${antflags} test || die "Testing Classes Failed"
- fi
+ use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadoc"
- if use doc; then
- ant javadoc || die "Unable to create documents"
- fi
+ ant ${antflags} || die "Compilation Failed"
}
-src_install () {
+src_install() {
java-pkg_dojar dist/${PN}.jar
dodoc README.txt
dohtml STATUS.html PROPOSAL.html
- use doc && java-pkg_dohtml -r dist/docs/*
+ use doc && java-pkg_dohtml -r dist/docs/*
}