summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-03 15:19:17 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-03 15:19:17 +0000
commit9806fbaa95015927df370aed29798e8c25e3812d (patch)
tree85de4061494068e7e62ce178e0f6f25180d371d3
parentfixed lapack libs when threaded, cleaned-up lapack/fortran stuff (diff)
downloadhistorical-9806fbaa95015927df370aed29798e8c25e3812d.tar.gz
historical-9806fbaa95015927df370aed29798e8c25e3812d.tar.bz2
historical-9806fbaa95015927df370aed29798e8c25e3812d.zip
old
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.133
-rw-r--r--sys-apps/util-linux/util-linux-2.13.ebuild74
2 files changed, 0 insertions, 77 deletions
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13 b/sys-apps/util-linux/files/digest-util-linux-2.13
deleted file mode 100644
index a2e47b157d36..000000000000
--- a/sys-apps/util-linux/files/digest-util-linux-2.13
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2175a6e64ba0cf8ff05402eaee33e4b0 util-linux-ng-2.13.tar.bz2 2702618
-RMD160 499b1c5c2060b23d8bf504122a22122af99eb7fa util-linux-ng-2.13.tar.bz2 2702618
-SHA256 002412e93d8e85b1796fdbe65bbb0a4d193d0317a7155fda4270667e08bdfbfc util-linux-ng-2.13.tar.bz2 2702618
diff --git a/sys-apps/util-linux/util-linux-2.13.ebuild b/sys-apps/util-linux/util-linux-2.13.ebuild
deleted file mode 100644
index d0cf973480b1..000000000000
--- a/sys-apps/util-linux/util-linux-2.13.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.ebuild,v 1.2 2007/08/28 14:03:09 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls old-linux selinux"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-fs/e2fsprogs-1.34
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- fi
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use_with selinux) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-}