summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-13 00:07:40 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-13 00:07:40 +0000
commit9807b74a2d377a363bd32bddef7fe7428e7ea482 (patch)
tree79fba57d96b27469bf6eb0c3df7f8b6ee54d2129
parentGNOME 2.1.2 commit (diff)
downloadhistorical-9807b74a2d377a363bd32bddef7fe7428e7ea482.tar.gz
historical-9807b74a2d377a363bd32bddef7fe7428e7ea482.tar.bz2
historical-9807b74a2d377a363bd32bddef7fe7428e7ea482.zip
GNOME 2.1.2 commit
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.1.21
-rw-r--r--x11-libs/gtk+/gtk+-2.1.2.ebuild68
-rw-r--r--x11-libs/libwnck/ChangeLog7
-rw-r--r--x11-libs/libwnck/files/digest-libwnck-2.1.31
-rw-r--r--x11-libs/libwnck/libwnck-2.1.3.ebuild26
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.1.31
-rw-r--r--x11-libs/pango/pango-1.1.3.ebuild52
-rw-r--r--x11-libs/startup-notification/startup-notification-0.3.ebuild4
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/files/digest-vte-0.10.41
-rw-r--r--x11-libs/vte/vte-0.10.4.ebuild28
13 files changed, 203 insertions, 8 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index de7041a6c993..692bb5b98aa0 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.34 2002/11/12 12:28:31 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.35 2002/11/13 00:07:40 foser Exp $
+*gtk+-2.1.2 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> gtk+-2.1.2.ebuild :
+ GNOME 2.1.2 release
*gtk+-2.0.8 (09 Nov 2002)
@@ -14,8 +18,6 @@
09 Nov 2002; Spider <spider@gentoo.org> gtk+-2.0.8.ebuild
files/digest-gtk+-2.0.8 : New version fixes the patch needed for last version
also fixed the dependencies, after 2.0.7-r1.
-
-
*gtk+-2.0.7-r1 (05 Nov 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.1.2 b/x11-libs/gtk+/files/digest-gtk+-2.1.2
new file mode 100644
index 000000000000..1a395b0f58ef
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.1.2
@@ -0,0 +1 @@
+MD5 b5d9c50ce7e09f78a18047ddcf60de6d gtk+-2.1.2.tar.bz2 6174940
diff --git a/x11-libs/gtk+/gtk+-2.1.2.ebuild b/x11-libs/gtk+/gtk+-2.1.2.ebuild
new file mode 100644
index 000000000000..b217a8d13a4e
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.1.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.2.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+
+IUSE="tiff doc jpeg directfb"
+
+inherit libtool flag-o-matic debug
+
+SLOT="2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.6-r1
+ =dev-libs/atk-1.1*
+ =x11-libs/pango-1.1*
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9
+ app-text/sgmltools-lite )"
+
+src_compile() {
+ # see bug 8762
+ replace-flags "-O3" "-O2"
+
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf --with-gdktarget=x11 ${myconf} || die
+
+ # gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+ gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+}
+
diff --git a/x11-libs/libwnck/ChangeLog b/x11-libs/libwnck/ChangeLog
index e8a4dff4ceef..210a37ff7778 100644
--- a/x11-libs/libwnck/ChangeLog
+++ b/x11-libs/libwnck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libwnck
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.11 2002/10/27 15:19:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.12 2002/11/13 00:07:40 foser Exp $
+
+*libwnck-2.1.3 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> libwnck-2.1.3.ebuild :
+ GNOME 2.1.2 release
*libwnck-2.1.1 (27 Oct 2002)
diff --git a/x11-libs/libwnck/files/digest-libwnck-2.1.3 b/x11-libs/libwnck/files/digest-libwnck-2.1.3
new file mode 100644
index 000000000000..d8af3b6cfe51
--- /dev/null
+++ b/x11-libs/libwnck/files/digest-libwnck-2.1.3
@@ -0,0 +1 @@
+MD5 38e0a78dd55d30436da7c71668dfc224 libwnck-2.1.3.tar.bz2 231206
diff --git a/x11-libs/libwnck/libwnck-2.1.3.ebuild b/x11-libs/libwnck/libwnck-2.1.3.ebuild
new file mode 100644
index 000000000000..18407bda39d2
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-2.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-2.1.3.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+
+inherit gnome2 debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+
+RDEPEND="virtual/glibc
+ =x11-libs/pango-1.1*
+ dev-libs/glib
+ =x11-libs/gtk+-2.1*"
+DEPEND=">=dev-util/pkgconfig-0.12.0 ${RDEPEND}"
+
+
+LICENSE="GPL-2"
+DOCS="ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+
+
+
+
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 03be55c1d555..e276c695336c 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.15 2002/11/02 22:26:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.16 2002/11/13 00:07:40 foser Exp $
+
+*pango-1.1.3 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> pango-1.1.3.ebuild :
+ GNOME 2.1.2 release
*pango-1.1.2 (27 Oct 2002)
diff --git a/x11-libs/pango/files/digest-pango-1.1.3 b/x11-libs/pango/files/digest-pango-1.1.3
new file mode 100644
index 000000000000..d83c5c887b83
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.1.3
@@ -0,0 +1 @@
+MD5 34f4c5486b9428d8c738acc0c76ed669 pango-1.1.3.tar.bz2 766579
diff --git a/x11-libs/pango/pango-1.1.3.ebuild b/x11-libs/pango/pango-1.1.3.ebuild
new file mode 100644
index 000000000000..1060f330cae3
--- /dev/null
+++ b/x11-libs/pango/pango-1.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.1.3.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+
+IUSE="doc"
+
+inherit libtool debug
+
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}
+
diff --git a/x11-libs/startup-notification/startup-notification-0.3.ebuild b/x11-libs/startup-notification/startup-notification-0.3.ebuild
index 58ba54ddeab9..a63b818e090d 100644
--- a/x11-libs/startup-notification/startup-notification-0.3.ebuild
+++ b/x11-libs/startup-notification/startup-notification-0.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/startup-notification/startup-notification-0.3.ebuild,v 1.2 2002/11/03 18:30:29 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/startup-notification/startup-notification-0.3.ebuild,v 1.3 2002/11/13 00:07:40 foser Exp $
DESCRIPTION="Startup notification library"
HOMEPAGE="http://www.freedesktop.org/software/startup-notification/"
SRC_URI="${HOMEPAGE}/releases/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
IUSE=""
DEPEND="virtual/x11"
S="${WORKDIR}/${P}"
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 3dd6156dc82a..42e300c8c877 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.1 2002/10/28 12:39:56 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.2 2002/11/13 00:07:40 foser Exp $
+
+*vte-0.10.4 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> vte-0.10.4.ebuild :
+ GNOME 2.1.2 release
*vte-0.9.2 (28 Oct 2002)
diff --git a/x11-libs/vte/files/digest-vte-0.10.4 b/x11-libs/vte/files/digest-vte-0.10.4
new file mode 100644
index 000000000000..fd36a1489f3c
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.10.4
@@ -0,0 +1 @@
+MD5 3bef90f0b51da980aa471eaa65baf552 vte-0.10.4.tar.bz2 668647
diff --git a/x11-libs/vte/vte-0.10.4.ebuild b/x11-libs/vte/vte-0.10.4.ebuild
new file mode 100644
index 000000000000..66de944f08d5
--- /dev/null
+++ b/x11-libs/vte/vte-0.10.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.10.4.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+
+inherit gnome2 debug
+
+IUSE="doc"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome2 default icon theme"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-2
+ =x11-libs/pango-1.1*"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.6 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOC="AUTHORS COPY* README HACKING INSTALL NEWS TODO ChangeLog"
+
+
+