summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-03 21:38:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-03 21:38:49 +0000
commit9a17019c8698b125c582ef5cd2f7adb2b9f168d3 (patch)
tree537b7dbbe182ba37d637ef454378d529c29814de
parentStill masked in portage. Added a fix from Nicholas Wourms to enable (diff)
downloadhistorical-9a17019c8698b125c582ef5cd2f7adb2b9f168d3.tar.gz
historical-9a17019c8698b125c582ef5cd2f7adb2b9f168d3.tar.bz2
historical-9a17019c8698b125c582ef5cd2f7adb2b9f168d3.zip
Initial import.
-rw-r--r--app-emulation/vice/ChangeLog8
-rw-r--r--app-emulation/vice/files/digest-vice-1.91
-rw-r--r--app-emulation/vice/vice-1.9.ebuild50
3 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
new file mode 100644
index 000000000000..2de3b69f1893
--- /dev/null
+++ b/app-emulation/vice/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/vice
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.1 2002/08/03 21:38:49 aliz Exp $
+
+*vice-1.9 (03 Aug 2002)
+
+ 03 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> vice-1.9.ebuild :
+ Initial import. Ebuild submitted by Matt Matthews <jvm@linuxgames.com>.
diff --git a/app-emulation/vice/files/digest-vice-1.9 b/app-emulation/vice/files/digest-vice-1.9
new file mode 100644
index 000000000000..d72ef7274189
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.9
@@ -0,0 +1 @@
+MD5 de3bc8d2fb32a6848aee2fe7233a7ca6 vice-1.9.tar.gz 3056898
diff --git a/app-emulation/vice/vice-1.9.ebuild b/app-emulation/vice/vice-1.9.ebuild
new file mode 100644
index 000000000000..4f4974a99069
--- /dev/null
+++ b/app-emulation/vice/vice-1.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.9.ebuild,v 1.1 2002/08/03 21:38:49 aliz Exp $
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://viceteam.bei.t-online.de/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=x11-base/xfree-4.0
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/gnome )"
+
+#RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--enable-fullscreen"
+ use sdl && myconf="${myconf} --with-sdl"
+ use gnome && myconf="${myconf} --enable-gnomeui"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dohtml ${D}/usr/lib/vice/doc/*.html
+ dodoc \
+ ${D}/usr/lib/vice/doc/NLS-Howto.txt \
+ ${D}/usr/lib/vice/doc/Readme.beos \
+ ${D}/usr/lib/vice/doc/Readme.dos \
+ ${D}/usr/lib/vice/doc/Win32-Howto.txt \
+ ${D}/usr/lib/vice/doc/mon.txt
+
+ rm ${D}/usr/lib/vice/doc -rf
+}