summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-14 18:47:07 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-14 18:47:07 +0000
commitae15172629fce8726e5a934f3bbc669a6ee7ec49 (patch)
treeadd00ea4dd3803e4c51a36ee08cc830053edf1af
parentreplaced hardcoding of apache path (diff)
downloadhistorical-ae15172629fce8726e5a934f3bbc669a6ee7ec49.tar.gz
historical-ae15172629fce8726e5a934f3bbc669a6ee7ec49.tar.bz2
historical-ae15172629fce8726e5a934f3bbc669a6ee7ec49.zip
replaced hardcoding of apache path
-rw-r--r--dev-db/mysqltool/ChangeLog14
-rw-r--r--dev-db/mysqltool/mysqltool-0.95-r1.ebuild21
2 files changed, 19 insertions, 16 deletions
diff --git a/dev-db/mysqltool/ChangeLog b/dev-db/mysqltool/ChangeLog
index 9b53cc057a9e..54f908397c13 100644
--- a/dev-db/mysqltool/ChangeLog
+++ b/dev-db/mysqltool/ChangeLog
@@ -1,26 +1,26 @@
# ChangeLog for dev-db/mysqltool
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.5 2002/11/10 00:36:14 rphillips Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.6 2002/11/14 18:47:07 vapier Exp $
*mysqltool-0.95-r1 (3 May 2002)
+ 14 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Replaced hardcoding of /home/httpd/htdocs with a grep of /etc/apache/conf/apache.conf
+
09 Nov 2002; <rphillips@gentoo.org> :
Added Paul Belt's fixes for the installation paths
- 15 Oct 2002; <mucmmings@gentoo.org> : Add sparc64 to keywords
+ 15 Oct 2002; <mucmmings@gentoo.org> :
+ Add sparc64 to keywords
9 Sep 2002; <mcummings@gentoo.org> :
-
Added perl-module eclass support properly.
3 May 2002; Donny Davies <woodchip@gentoo.org> :
-
Added LICENSE, SLOT.
*mysqltool-0.95 (17 Apr 2002)
17 Apr 2002; Donny Davies <woodchip@gentoo.org> :
-
Created an ebuild for mysqltool, a perl-based frontend for administering
MySQL servers. Similiar to phpMyAdmin.
-
diff --git a/dev-db/mysqltool/mysqltool-0.95-r1.ebuild b/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
index a70b753bafde..03f871570a8c 100644
--- a/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
+++ b/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r1.ebuild,v 1.6 2002/11/10 00:36:14 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r1.ebuild,v 1.7 2002/11/14 18:47:07 vapier Exp $
inherit perl-module
@@ -16,6 +16,9 @@ KEYWORDS="x86 sparc64"
RDEPEND="${DEPEND} >=net-www/apache-1.3.24-r1 >=dev-db/mysql-3.23.38
dev-perl/CGI dev-perl/DBI dev-perl/DBD-mysql dev-perl/Crypt-Blowfish"
+APACHE_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${APACHE_ROOT}" ] && APACHE_ROOT="/home/httpd/htdocs"
+
src_install() {
eval `perl '-V:installarchlib'`
mkdir -p ${D}/$installarchlib
@@ -29,9 +32,9 @@ src_install() {
dodoc COPYING Changes MANIFEST README Upgrade
# the cgi and images..
- dodir /home/httpd/htdocs/mysqltool
- cp -a htdocs/* ${D}/home/httpd/htdocs/mysqltool
- rm ${D}/home/httpd/htdocs/mysqltool/mysqltool.conf
+ dodir ${APACHE_ROOT}/mysqltool
+ cp -a htdocs/* ${D}${APACHE_ROOT}/mysqltool
+ rm ${D}${APACHE_ROOT}/mysqltool/mysqltool.conf
# the config file..
insinto /etc/apache/conf/addon-modules
@@ -40,10 +43,10 @@ src_install() {
fperms 0600 /etc/apache/conf/addon-modules/mysqltool.conf
# now fix its location in the main cgi..
- cp ${D}/home/httpd/htdocs/mysqltool/index.cgi \
- ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig
+ cp ${D}${APACHE_ROOT}/mysqltool/index.cgi \
+ ${D}${APACHE_ROOT}/mysqltool/index.cgi.orig
sed -e "s:^\(require\).*:\1 '/etc/apache/conf/addon-modules/mysqltool.conf';:" \
- ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig > \
- ${D}/home/httpd/htdocs/mysqltool/index.cgi
- rm ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig
+ ${D}${APACHE_ROOT}/mysqltool/index.cgi.orig > \
+ ${D}${APACHE_ROOT}/mysqltool/index.cgi
+ rm ${D}${APACHE_ROOT}/mysqltool/index.cgi.orig
}