summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-24 21:38:48 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-24 21:38:48 +0000
commitae403a5ad83930b63695355bf9dfa899970ebc5b (patch)
tree8e5ff1f12bafec4f756976b929d1f5d4db2a35b2
parentmade a few changes to some gnome scripts... (diff)
downloadhistorical-ae403a5ad83930b63695355bf9dfa899970ebc5b.tar.gz
historical-ae403a5ad83930b63695355bf9dfa899970ebc5b.tar.bz2
historical-ae403a5ad83930b63695355bf9dfa899970ebc5b.zip
Version bump, latest fetchmail.
-rw-r--r--net-mail/fetchmail/ChangeLog7
-rw-r--r--net-mail/fetchmail/fetchmail-6.2.2.ebuild73
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.2.21
3 files changed, 80 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index d89d56796017..c3ce00210ea3 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/fetchmail
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.26 2003/03/19 17:33:51 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.27 2003/03/24 21:38:48 avenj Exp $
+
+*fetchmail-6.2.2 (24 Mar 2003)
+
+ 24 Mar 2003; Jon Portnoy <avenj@gentoo.org> fetchmail-6.2.2.ebuild :
+ Version bump, latest fetchmail.
05 Feb 2003; Aron Griffis <agriffis@gentoo.org> fetchmail-6.2.1-r1.ebuild :
Mark stable on alpha
diff --git a/net-mail/fetchmail/fetchmail-6.2.2.ebuild b/net-mail/fetchmail/fetchmail-6.2.2.ebuild
new file mode 100644
index 000000000000..980511545e7a
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.2.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.2.2.ebuild,v 1.1 2003/03/24 21:38:48 avenj Exp $
+
+inherit eutils
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.catb.org/~esr/fetchmail/"
+SRC_URI="http://www.catb.org/~esr/fetchmail/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86 ~alpha"
+IUSE="ssl nls ipv6"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fetchmail-6.2.0-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use nls || myconf="${myconf} --disable-nls"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ einstall || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman ${D}/usr/share/man/*.1
+ rm -f ${D}/usr/share/man/*.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.2.2 b/net-mail/fetchmail/files/digest-fetchmail-6.2.2
new file mode 100644
index 000000000000..a1f977811cec
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.2.2
@@ -0,0 +1 @@
+MD5 b3544890a2452b5b04c709c65109c43a fetchmail-6.2.2.tar.gz 1205198