summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
commitb116ad28dc0d2e194b9c52d9e51a18f2a59a5c84 (patch)
tree0452df37d93b66ec9e09a3823b6ec56fe169cd76
parentVersion bump (diff)
downloadhistorical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.gz
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.bz2
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.zip
Version bump.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
-rw-r--r--dev-ruby/daemon_controller/ChangeLog10
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild27
-rw-r--r--dev-ruby/hoe-seattlerb/ChangeLog8
-rw-r--r--dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.5.ebuild26
-rw-r--r--dev-ruby/parsetree/ChangeLog7
-rw-r--r--dev-ruby/parsetree/parsetree-3.0.7.ebuild87
-rw-r--r--dev-ruby/rake-remote_task/Manifest12
-rw-r--r--dev-ruby/ruby-inline/ChangeLog7
-rw-r--r--dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild57
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild34
-rw-r--r--dev-ruby/zentest/ChangeLog7
-rw-r--r--dev-ruby/zentest/zentest-4.5.0.ebuild40
13 files changed, 314 insertions, 15 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index 37a85cdd3969..0dd4aa1a1296 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemon_controller
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.1 2010/10/25 19:57:19 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.2 2011/02/19 08:29:08 graaff Exp $
+
+*daemon_controller-0.2.6 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +daemon_controller-0.2.6.ebuild:
+ Version bump.
*daemon_controller-0.2.5 (25 Oct 2010)
diff --git a/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild b/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild
new file mode 100644
index 000000000000..32ce8c5ccd2b
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild,v 1.1 2011/02/19 08:29:08 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust, race-condition-free manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec ) "
+
+each_ruby_test() {
+ ${RUBY} -S spec spec || die "Tests failed."
+}
diff --git a/dev-ruby/hoe-seattlerb/ChangeLog b/dev-ruby/hoe-seattlerb/ChangeLog
index 7d2f63a8db00..8bd5963e6e3b 100644
--- a/dev-ruby/hoe-seattlerb/ChangeLog
+++ b/dev-ruby/hoe-seattlerb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe-seattlerb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.23 2011/02/16 09:47:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/ChangeLog,v 1.24 2011/02/19 08:29:42 graaff Exp $
+
+*hoe-seattlerb-1.2.5 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +hoe-seattlerb-1.2.5.ebuild:
+ Version bump.
16 Feb 2011; Markos Chandras <hwoarang@gentoo.org>
hoe-seattlerb-1.2.4.ebuild:
diff --git a/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.5.ebuild b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.5.ebuild
new file mode 100644
index 000000000000..887e5b8cb23c
--- /dev/null
+++ b/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe-seattlerb/hoe-seattlerb-1.2.5.ebuild,v 1.1 2011/02/19 08:29:42 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# no tests present
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
+HOMEPAGE="http://seattlerb.rubyforge.org/hoe-seattlerb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/hoe-2.9.1 >=dev-ruby/minitest-2.0.2'
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.2.3 )"
diff --git a/dev-ruby/parsetree/ChangeLog b/dev-ruby/parsetree/ChangeLog
index 2c8271ec2da1..561952eada7f 100644
--- a/dev-ruby/parsetree/ChangeLog
+++ b/dev-ruby/parsetree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/parsetree
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.36 2011/01/22 15:21:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.37 2011/02/19 08:30:10 graaff Exp $
+
+*parsetree-3.0.7 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +parsetree-3.0.7.ebuild:
+ Version bump.
22 Jan 2011; Hans de Graaff <graaff@gentoo.org>
-parsetree-3.0.5-r1.ebuild, -parsetree-3.0.5-r2.ebuild:
diff --git a/dev-ruby/parsetree/parsetree-3.0.7.ebuild b/dev-ruby/parsetree/parsetree-3.0.7.ebuild
new file mode 100644
index 000000000000..debd7e4859da
--- /dev/null
+++ b/dev-ruby/parsetree/parsetree-3.0.7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/parsetree-3.0.7.ebuild,v 1.1 2011/02/19 08:30:10 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_NAME="ParseTree"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="ParseTree extracts the parse tree for a Class or method and returns it as a s-expression."
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '
+ >=dev-ruby/ruby-inline-3.7.0
+ >=dev-ruby/sexp-processor-3.0.0'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest
+ dev-ruby/ruby2ruby
+ )
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )"
+
+all_ruby_prepare() {
+ # Fix USE=doc by removing the path that triggers running the tests
+ # and thus building the extensions in the wrong way.
+ sed -i -e '/require_paths/d' Rakefile || die
+
+}
+
+each_ruby_prepare() {
+ # RubyInline employs a very stupid caching strategy solely based on
+ # the public signatures of methods. Never mind bugs within the C
+ # code... We add a dynamic method name to the parsetree interface
+ # just so that we can guarantee compilation. Fixes #329497.
+ epatch "${FILESDIR}/${PN}-3.0.6-timestamp.patch"
+ sed -i -e "s/TIMESTAMP/$(date +%s)/" lib/parse_tree.rb || die
+}
+
+src_compile() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+each_ruby_compile() {
+ # The ruby extension uses RubyInline to use C code within Ruby;
+ # since it causes us no little pain, we'll do our best here to
+ # prebuild the extensions.
+
+ INLINEDIR="${PWD}" ${RUBY} -Ilib -rparse_tree -e '' || die "Unable to load ${PN}"
+
+ mkdir lib/inline
+ cp .ruby_inline/*$(get_modname) lib/inline/ || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+pkg_postinst() {
+ elog "${CATEGORY}/${PN} uses the RubyInline library to build its parser."
+ elog "RubyInline builds loadable extensions at runtime in your home"
+ elog "directory if they are not supplied by the gems."
+ elog ""
+ elog "We are currently providing you with pre-built extensions for"
+ elog "the Ruby implementations you're using. Unfortunately these are"
+ elog "different from version to version, so you might have to"
+ elog "rebuild ${CATEGORY}/${PN} after each update to dev-lang/ruby or"
+ elog "dev-lang/ruby-enterprise."
+}
diff --git a/dev-ruby/rake-remote_task/Manifest b/dev-ruby/rake-remote_task/Manifest
index b219e3f0eba9..56af5879b01b 100644
--- a/dev-ruby/rake-remote_task/Manifest
+++ b/dev-ruby/rake-remote_task/Manifest
@@ -1,18 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
-DIST rake-remote_task-2.0.0.gem 15360 RMD160 106d692e0d59512ac8bfd968b14087fa262470d6 SHA1 6d662507073377aabaf22ea9746fd36b764f73a8 SHA256 3e844da9ecac9a3985d381d3ef55e70e2cd2ef87c7e47c07bb659f0f50260676
-DIST rake-remote_task-2.0.1.gem 15360 RMD160 0767afab5504943911032ddb923dd15f3db9a98b SHA1 3de48ccb8680b08ef189d2178195f1bcab878d88 SHA256 4afb0d2946255dd443d61ad6a483eedade62cc797734e8ae942c5616dd752fe4
DIST rake-remote_task-2.0.2.gem 15360 RMD160 9e795ed281ac2c9f08804835faf35c5f4ee75873 SHA1 9304508b579654e93d53b8997890242eabec89f6 SHA256 dbd91ecd706a81e43afcdba2c916a9af24e4489407017789e405e52351694586
-EBUILD rake-remote_task-2.0.0.ebuild 767 RMD160 7022a16fd76ac8a703f4c71602f00706d755aee1 SHA1 a004053c7ccca1765c9c8b045e3e09b2a36d7669 SHA256 373143e7fe6231788f58757a9b9455f9b8ecbf7d5adeaad39287181ed9898792
-EBUILD rake-remote_task-2.0.1.ebuild 767 RMD160 8568497166514bb695b98abca4c3a3507a2d2a80 SHA1 0e84cecae8e43ee24ee9f3971cbe8bd25009d252 SHA256 37714e4c2efc4b6935c8fdd84f5f828079b3f0a8e8639662cc57c79db39d214d
EBUILD rake-remote_task-2.0.2.ebuild 764 RMD160 9bf3c771d13c9a55f82dd187cdcb018ad5aa619f SHA1 1a8416b0a79b309f9b59d9ec436a70e7059d69ec SHA256 3c1367222d3c9f17d086c01f87e43a9549e8a5f1ed92f81731eb6f9949ac60af
-MISC ChangeLog 909 RMD160 7ff6adbbf72cc6af79e582673999a14d0e859b08 SHA1 bd3749ebb445e6b62499ca42f4f83d0996de5c52 SHA256 f3e1d6f4bf4a3869ab0b4192b97ee2602279f9adef2fa9fa41c6eac0a927e052
+MISC ChangeLog 1049 RMD160 414d4252284f1a0df73c38bfbdc03b1a707674ed SHA1 046c7bc84c7ca8a4173bb689f9244a5ae9449a10 SHA256 0efadaa378a8c819aa46226c80962a82c560b1ca7868f65f9f8246d55d2a61ea
MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
-iF4EAREIAAYFAkym+gUACgkQZihJkut28StDygEAv+kQdJcC+Fydqf6Fjjb5Bl04
-oBQAlIc1GxH3jsrDmPMA/AjGCvgTw1e2HB3Ebm6/OFaqpeat/rHvrUr+YARiv3Gs
-=Wrd3
+iF4EAREIAAYFAk1fgAkACgkQrnu0mw69Jko29QD+NPpVdK7jLsfYGeO8dUaxaVgj
+5dG8oKkKS6UaemFDWz0A/iVxPPSg17uWFKEV+T1YUm8SuXkNOFkAaXfLeKexxSbm
+=qxNN
-----END PGP SIGNATURE-----
diff --git a/dev-ruby/ruby-inline/ChangeLog b/dev-ruby/ruby-inline/ChangeLog
index 7f76911f2468..8a572648abb3 100644
--- a/dev-ruby/ruby-inline/ChangeLog
+++ b/dev-ruby/ruby-inline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-inline
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.34 2011/02/17 07:04:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.35 2011/02/19 08:30:41 graaff Exp $
+
+*ruby-inline-3.9.0 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +ruby-inline-3.9.0.ebuild:
+ Version bump.
*ruby-inline-3.8.6-r1 (17 Feb 2011)
diff --git a/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild b/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild
new file mode 100644
index 000000000000..3b72a2e37616
--- /dev/null
+++ b/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild,v 1.1 2011/02/19 08:30:41 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RubyInline"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # we have to patch the code so that it takes the RUBY_DESCRIPTION
+ # into consideration, to avoid loading Ruby-Enterprise (REE18)
+ # objects in MRI and vice-versa; we're a bit “greedier” since we
+ # will rebuild objects even when just switching versions, but
+ # it'll be better this way than being too conservatives.
+ epatch "${FILESDIR}/${PN}-3.8.4-gentoo.patch"
+
+ # Respect ruby's (and thus Gentoo's) LDFLAGS, and explicitly link
+ # against the ruby shared library to avoid confusion and potential
+ # crashes when later using the shared object.
+ epatch "${FILESDIR}/${PN}-3.8.4-ldflags.patch"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb || die
+}
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index e3463960bc04..66a3bfa0cfbe 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.19 2011/02/17 07:02:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.20 2011/02/19 08:31:12 graaff Exp $
+
+*ruby_parser-2.0.6 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +ruby_parser-2.0.6.ebuild:
+ Version bump.
17 Feb 2011; Hans de Graaff <graaff@gentoo.org>
-ruby_parser-2.0.4-r1.ebuild:
diff --git a/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild b/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild
new file mode 100644
index 000000000000..000b7051065f
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild,v 1.1 2011/02/19 08:31:12 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# Don't run tests, since they require the testcase from ParseTree;
+# ParseTree _is_ the testcase for ruby_parse
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby."
+HOMEPAGE="http://parsetree.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp-processor-3.0.1"
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ sed -i -e '/perforce/d' Rakefile || die
+}
diff --git a/dev-ruby/zentest/ChangeLog b/dev-ruby/zentest/ChangeLog
index 0ca336d4d79e..c2d8c52b3653 100644
--- a/dev-ruby/zentest/ChangeLog
+++ b/dev-ruby/zentest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/zentest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/zentest/ChangeLog,v 1.88 2011/02/16 09:47:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/zentest/ChangeLog,v 1.89 2011/02/19 08:28:24 graaff Exp $
+
+*zentest-4.5.0 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +zentest-4.5.0.ebuild:
+ Version bump.
16 Feb 2011; Markos Chandras <hwoarang@gentoo.org> zentest-4.4.2.ebuild:
Stable on amd64 wrt bug #354609
diff --git a/dev-ruby/zentest/zentest-4.5.0.ebuild b/dev-ruby/zentest/zentest-4.5.0.ebuild
new file mode 100644
index 000000000000..5838426838fc
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/zentest/zentest-4.5.0.ebuild,v 1.1 2011/02/19 08:28:24 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ZenTest provides tools to support testing: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="http://rubyforge.org/projects/zentest/"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? (
+ >=dev-ruby/hoe-2.6.1
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ >=dev-ruby/hoe-2.6.1
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+each_ruby_test() {
+ # JRuby needs the extended objectspace. We do it here
+ # unconditional in this easy way.
+ JRUBY_OPTS="${JRUBY_OPTS} -X+O" each_fakegem_test
+}