summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-05-08 19:25:23 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-05-08 19:25:23 +0000
commitb9e4df50529db8313b46f182d1b7292268031b20 (patch)
treeffb3f8cfb1098075d6de1091587d4b8ae70f4cf2
parentupdate to latest (diff)
downloadhistorical-b9e4df50529db8313b46f182d1b7292268031b20.tar.gz
historical-b9e4df50529db8313b46f182d1b7292268031b20.tar.bz2
historical-b9e4df50529db8313b46f182d1b7292268031b20.zip
fixed problem with the url
-rw-r--r--sys-libs/db/ChangeLog8
-rw-r--r--sys-libs/db/db-1.85-r1.ebuild4
-rw-r--r--sys-libs/db/db-1.85-r2.ebuild61
-rw-r--r--sys-libs/db/files/digest-db-1.85-r21
4 files changed, 71 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 0f67ce675ee9..d7a5ae0cf27d 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-libs/db
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.2 2002/03/21 11:30:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.3 2002/05/08 19:25:23 bass Exp $
*db-3.2.3h-r4 (21 Mar 2002)
@@ -19,3 +19,9 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
+
+*db-1.85-r2 (8 May 2002)
+
+ 1 Feb 2002; José Alberto Suárez López <bass@gentoo.org> Changelog db-1.85-r2.ebuild files/db-1.85-r2.digest :
+
+ Fixed an error with the source url.
diff --git a/sys-libs/db/db-1.85-r1.ebuild b/sys-libs/db/db-1.85-r1.ebuild
index e856d190db23..7f962ad72cec 100644
--- a/sys-libs/db/db-1.85-r1.ebuild
+++ b/sys-libs/db/db-1.85-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r1.ebuild,v 1.5 2002/02/10 16:43:43 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r1.ebuild,v 1.6 2002/05/08 19:25:23 bass Exp $
S=${WORKDIR}/db.${PV}
DESCRIPTION="db 1.85 -- required for RPM 4.0 to compile; that's about it."
-SRC_URI="http://www.sleepycat.com/update/${PV}/db.${PV}.tar.gz"
+SRC_URI="http://www.sleepycat.com/update/snapshot/db.${PV}.tar.gz"
HOMEPAGE="http://www.sleepycat.com"
DEPEND="virtual/glibc"
RDEPEND=$DEPEND
diff --git a/sys-libs/db/db-1.85-r2.ebuild b/sys-libs/db/db-1.85-r2.ebuild
new file mode 100644
index 000000000000..4a8252700f97
--- /dev/null
+++ b/sys-libs/db/db-1.85-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r2.ebuild,v 1.1 2002/05/08 19:25:23 bass Exp $
+
+S=${WORKDIR}/db.${PV}
+DESCRIPTION="db 1.85 -- required for RPM 4.0 to compile; that's about it."
+SRC_URI="http://www.sleepycat.com/update/snapshot/db.${PV}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+DEPEND="virtual/glibc"
+RDEPEND=$DEPEND
+SLOT="1"
+src_unpack() {
+
+ unpack db.${PV}.tar.gz
+ cd ${S}
+ patch -p1 < ${FILESDIR}/db.${PV}.patch
+
+}
+
+src_compile() {
+
+ cd ${S}/PORT/linux
+ make ${MAKEOPTS} OORG="${CFLAGS} -fomit-frame-pointer" prefix=/usr || die
+
+}
+
+src_install () {
+
+ cd ${S}/PORT/linux
+
+ cp libdb.a libdb1.a
+ dolib.a libdb1.a
+ cp libdb.so.2 libdb1.so.2
+ dolib.so libdb1.so.2
+ dosym libdb1.so.2 /usr/lib/libdb1.so
+ dosym libdb1.so.2 /usr/lib/libdb.so.2
+ dosym libdb1.so.2 /usr/lib/libndbm.so
+ dosym libdb1.a /usr/lib/libndbm.a
+
+ dodir /usr/include/db1
+ insinto /usr/include/db1
+ doins include/db.h include/mpool.h
+
+ insinto /usr/include/db1
+ doins include/ndbm.h
+ dosed "s:<db.h>:<db1/db.h>:" /usr/include/db1/ndbm.h
+ dosym db1/ndbm.h /usr/include/ndbm.h
+ cp db_dump185 db1_dump185
+ dobin db1_dump185
+
+ cd ${S}
+ dodoc changelog README
+ docinto ps
+ dodoc docs/*.ps
+ docinto hash
+ dodoc hash/README
+
+}
+
+
diff --git a/sys-libs/db/files/digest-db-1.85-r2 b/sys-libs/db/files/digest-db-1.85-r2
new file mode 100644
index 000000000000..61ec3a1f9af0
--- /dev/null
+++ b/sys-libs/db/files/digest-db-1.85-r2
@@ -0,0 +1 @@
+MD5 42cc6c1e1e25818bd3e3f91328edb0f1 db.1.85.tar.gz 270953